Задать вопрос
20 октября, 17:30

Найти наибольшие и наименьшие элементы прямоугольной матрицы и поменять их местами

+4
Ответы (1)
  1. 20 октября, 21:14
    0
    Const m=5; n=6;

    var

    a:array[1 ... m, 1 ... n] of integer;

    i, j, max, imax, jmax, min, imin, jmin:integer;

    begin

    Randomize;

    writeln ('Исходный массив:') ;

    for i:=1 to m do

    begin

    for j:=1 to n do

    begin

    a[i, j]:=random (100) ;

    write (a[i, j]:4) ;

    end;

    writeln;

    end;

    max:=a[1,1]; imax:=1; jmax:=1;

    min:=a[1,1]; imin:=1; jmin:=1;

    for i:=1 to m do

    for j:=1 to n do

    begin

    if a[i, j]>max then begin max:=a[i, j]; imax:=i; jmax:=j; end;

    if a[i, j]
    end;

    writeln ('max = a[', imax,',', jmax,'] = ', max) ;

    writeln ('min = a[', imin,',', jmin,'] = ', min) ;

    a[imax, jmax]:=min;

    a[imin, jmin]:=max;

    writeln ('Полученный массив:') ;

    for i:=1 to m do

    begin

    for j:=1 to n do write (a[i, j]:4) ;

    writeln;

    end;

    end.

    Пример:

    Исходный массив:

    69 2 25 92 32 43

    98 77 49 29 48 5

    30 8 95 83 37 83

    31 6 47 91 82 65

    86 31 62 70 82 38

    max = a[2,1] = 98

    min = a[1,2] = 2

    Полученный массив:

    69 98 25 92 32 43

    2 77 49 29 48 5

    30 8 95 83 37 83

    31 6 47 91 82 65

    86 31 62 70 82 38
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Найти наибольшие и наименьшие элементы прямоугольной матрицы и поменять их местами ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Для матрицы размером в n строк и m столбцов составить алгоритм и программу вычисления: 1) Сумм элементов каждой нечетной строки матрицы 2) Суммы произведений тангенсов элементов четных строк матрицы.
Ответы (1)
Напишите программу, которая обнуляет все элементы квадратной матрицы, расположенные выше главной диагонали. Входные данные В первой строке записаны через пробел размер квадратной матрицы N (количество строк равно количеству столбцов) (1 ≤ N ≤ 100).
Ответы (1)
1. Из заданной матрицы А (7 х7), элементы которой формируются как массив случайных чисел, сформировать одномерный массив В, состоящий из диагональных элементов матрицы А.
Ответы (1)
Помогите написать программу на VisualBasic! Дана матрица Y (5,5) (элементы матрицы выбрать самостоятельно). Вы- числить элементы новой матрицы Z (5,5) по правилу: zij = yij / ki, где ki - количе- ство положительных элементов i-той строки.
Ответы (1)
1. Имеется одномерный массив размерностью 20, заполненный рандомными числами на отрезке от 1 до 20. Требуется удалить из него максимальный и минимальный элементы Примечание: Алгоритм удаления: сдвигаются все элементы на 1 позицию влево, начиная с
Ответы (1)