Задать вопрос
18 ноября, 10:17

Информатика: (Pascal abc) Дано трехзначное число, определить сумму, произведение, средне арифметическое значение цифр этого числа.

Поменяйте местами первую и третью цифру этого числа.

+2
Ответы (1)
  1. 18 ноября, 11:32
    0
    Var sum, p, x, z:integer;

    begin

    writeln ('Введите трёхзначное число') ;

    read (x) ;

    sum:=x mod 10 + x div 100 + x div 10 mod 10;

    p: = (x mod 10) * (x div 100) * (x div 10 mod 10) ;

    z: = (x mod 10 * 100) + (x div 10 mod 10 * 10) + (x div 100) ;

    writeln ('Сумма цифр = ', sum) ;

    writeln ('Среднее арифметическое цифр = ', sum/3) ;

    writeln ('Произведение цифр = ', p) ;

    writeln ('После перестановки 1 и 3 цифр = ', z) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Информатика: (Pascal abc) Дано трехзначное число, определить сумму, произведение, средне арифметическое значение цифр этого числа. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Дано натуральное число: определить а) количество цифр в нем б) сумму его цифр в) произведение его цифр г) среднее арифметическое его цифр д) сумму квадратов его цифр е) сумму кубов его цифр ж) его первую цифру з) сумму его первой и последней цифр
Ответы (1)
Решить задачи • Найдите сумму цифр числа; • Найдите первую цифру числа; • Поменяйте порядок цифр числа на обратный; • Найдите количество четных цифр числа; • Найдите наибольшую цифру числа; • Найдите сумму цифр числа, больших 5.
Ответы (1)
Помогите решить! 1) Дано натуральное трехзначное число N. Определить сумму и произведение его цифр. 2) Дано натуральное трехзначное число N. Найдите число, образованное перестановкой цифр исходного числа в обратном порядке.
Ответы (1)
Паскаль. 1) Дано трехзначное число, нужно найти число, полученное при прочтении его цифр справа налево. 2) Дано трехзначное число. В нем зачеркнули последнюю справа цифру и приписали ее в начале. Найти полученное число. 3) Дано трехзначное число.
Ответы (1)
1. Составьте программу в Pascal ABC. Известно, что X кг конфет стоит A рублей. Определить, сколько стоит 1 кг и Y кг этих же конфет. 2. Составьте программу в Pascal ABC. Дано двузначное число. Найти сумму и произведение его цифр. 3.
Ответы (1)