Задать вопрос
30 декабря, 23:38

Написать программу: дано натуральное число. верно ли, что данное число начинается на нечетную цифру

+3
Ответы (1)
  1. 31 декабря, 00:10
    0
    Var

    i, d: integer;

    begin

    readln (d) ;

    while d > 0 do

    begin

    i : = d mod 10;

    d : = d div 10;

    end;

    write (i mod 2 = 1) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Написать программу: дано натуральное число. верно ли, что данное число начинается на нечетную цифру ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Дано натуральное число: 1) найти количество цифр данного числа 2) Верно ли что данное число оканчивается на нечетную цифру
Ответы (1)
1. Дано натуральное число. Найти первую цифру данного числа. 2. Дано натуральное число. Определить количество троек в нем. 3. Дано натуральное число. Определить количество четных цифр в нем. Все это при помощи цикла:while
Ответы (1)
Написать на Python 1. а) дано натуральное число провериться заканчивается ли оно на 5 б) проверить заканчивается ли оно на нечетную цифру?
Ответы (1)
6.22) Дано натуральное число. Определить: а) количество цифр 3 в нем; б) сумму его цифр, больших пяти; в) произведение его цифр, больших семи; 6.26) Дано натуральное число. а) определить его максимальную цифру. б) определить его минимальную цифру.
Ответы (1)
1. Дано натуральное число. Верно ли, что сумма его цифр есть четное число, а само число не превышает b? 2. Дано натуральное число. Верно ли, что сумма его цифр больше m а само число делится на n?
Ответы (1)