Задать вопрос
24 апреля, 16:04

1. Дано натуральное число:

1) найти количество цифр данного числа

2) Верно ли что данное число оканчивается на нечетную цифру

+2
Ответы (1)
  1. 24 апреля, 17:20
    0
    на паскале:

    var

    n, s, p:integer;

    begin

    read (n) ;

    p:=n mod 10;

    if p mod 2=0 then writeln ('оканчивается на четную цифру')

    else writeln ('оканчивается на четную цифру') ;

    while n>0 do

    begin

    n:=n div 10;

    s:=s+1;

    end;

    writeln ('количество цифр в числе', s) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «1. Дано натуральное число: 1) найти количество цифр данного числа 2) Верно ли что данное число оканчивается на нечетную цифру ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Дано натуральное число. Найти первую цифру данного числа. 2. Дано натуральное число. Определить количество троек в нем. 3. Дано натуральное число. Определить количество четных цифр в нем. Все это при помощи цикла:while
Ответы (1)
6.22) Дано натуральное число. Определить: а) количество цифр 3 в нем; б) сумму его цифр, больших пяти; в) произведение его цифр, больших семи; 6.26) Дано натуральное число. а) определить его максимальную цифру. б) определить его минимальную цифру.
Ответы (1)
Написать программу: дано натуральное число. верно ли, что данное число начинается на нечетную цифру
Ответы (1)
Дано натуральное число: определить а) количество цифр в нем б) сумму его цифр в) произведение его цифр г) среднее арифметическое его цифр д) сумму квадратов его цифр е) сумму кубов его цифр ж) его первую цифру з) сумму его первой и последней цифр
Ответы (1)
Решить задачи • Найдите сумму цифр числа; • Найдите первую цифру числа; • Поменяйте порядок цифр числа на обратный; • Найдите количество четных цифр числа; • Найдите наибольшую цифру числа; • Найдите сумму цифр числа, больших 5.
Ответы (1)