Задать вопрос
15 сентября, 14:30

В программе Алго, напишите программу для нахождения произведения цифр натурального числа N, введенного с клавиатуры.

+1
Ответы (1)
  1. 15 сентября, 16:55
    0
    Программа написана на языке программирования Pascal

    program z1;

    var N, p, n1, i:integer;

    begin

    writeln ('Введите число N') ;

    readln (N) ;

    p:=1;

    for i:=1 to n do

    if N>0

    then begin n1:=N mod 10; p:=p*n1; N:=N div 10; end;

    write ('Произведение=', p) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «В программе Алго, напишите программу для нахождения произведения цифр натурального числа N, введенного с клавиатуры. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Pascal. Требуется помощь. Составьте программу вычисления суммы цифр введённого с клавиатуры трёхзначного натурального числа. Например, для числа 128 сумма цифр 11, для числа 345 сумма цифр 12.
Ответы (1)
составить программу вычисления суммы цифр введенного с клавиатуры 3 - х значного натурального числа. Например для числа 128 сумма цифр 11, а для числа 345 сумма цифр12.
Ответы (2)
1. Составьте программу, которая определяет, является ли сумма цифр введенного целого трехзначного числа четным числом. 2. Составьте программу, которая определяет, является ли последняя цифра введенного целого числа нечетным числом. 8 класс.
Ответы (1)
1) Напишите программу, которая строит "квадрат" из знаков '*' заданного размера. Используйте процедуру. 2) Напишите программу, которая выводит в столбик цифры введённого числа, начиная с последней. Используйте процедуру.
Ответы (1)
Вычислить Y в зависимости от x, введенного с клавиатуры Y = (х2, если х>0 х+1, если х
Ответы (1)