Задать вопрос
17 октября, 19:21

Вычислить Y в зависимости от x, введенного с клавиатуры Y = (х2, если х>0

х+1, если х<=0

2 задача - вычислить Y в зависимости от x, введенного с клавиатуры (12,5*2, если - 1<=х<0

х-1, если х<-1

12 х, если х>0

+5
Ответы (1)
  1. 17 октября, 20:51
    0
    Первая:

    var

    x, y:integer;

    begin

    writeln ('Vvedite x') ;

    readln (x) ;

    if x>0 then

    y:=sqr (x)

    else

    y:=x+1;

    writeln (y) ;

    end.

    Вторая

    var

    x:integer;

    y:real;

    begin

    writeln ('vvedite x') ;

    readln (x) ;

    if (x=-1) then

    y:=12.5*2

    else

    if x<-1 then

    y:=x-1

    else

    y:=12*x;

    writeln (y) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Вычислить Y в зависимости от x, введенного с клавиатуры Y = (х2, если х>0 х+1, если х ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1) Напишите программы, которые в зависимости от введенного числа либо вычисляют функцию, либо выдают сообщение, что функция не определена.
Ответы (1)
1 задача. Вычислить произведение квадратов n первых натуральных чисел. Для любого n введенного с клвитуры. 2 Найти первое чётное натуральное числоЮ куб которого больше числа x, введенного с клавитуры. 3. Даны вещественные числа b1, b2, ... b10.
Ответы (2)
Требуется написать программу которая в зависимости от введенного (с клавиатуры) увета светофора (1 - красный, 2-желтый, 3-зеленый) выводит, что требуется делать пешеходу (ждать, приготовится, идти)
Ответы (1)
1. Составьте программу, которая определяет, является ли сумма цифр введенного целого трехзначного числа четным числом. 2. Составьте программу, которая определяет, является ли последняя цифра введенного целого числа нечетным числом. 8 класс.
Ответы (1)
Вычислить сумму ряда для n введенного с клавиатуры S=1+1/2x+1/3x+1/nx
Ответы (1)