Задать вопрос
19 мая, 05:44

1 задача. Вычислить произведение квадратов n первых натуральных чисел. Для любого n введенного с клвитуры. 2 Найти первое чётное натуральное числоЮ куб которого больше числа x, введенного с клавитуры. 3. Даны вещественные числа b1, b2, ... b10. (ввести с клавитуры). Определите среднее арифметическое тех из них, которые кратны числу n, введенному с клавитуры.

+4
Ответы (2)
  1. 19 мая, 08:01
    0
    Pascal:

    1) Диапазоны не указаны, но для школы обычно хватает типа "Integer".

    var a, b, i:LongInt;

    begin

    write ('Введите число n=>') ;

    readln (a) ;

    b:=1;

    for i:=1 to a do

    b:=b * (i*i) ;

    write ('Произведение=', b, '.') ;

    readln end.
  2. 19 мая, 08:09
    0
    1) var s, i, n, a: integer;

    begin

    a:=1;

    s:=1;

    readln (n) ;

    for i:=1 to n do

    begin

    s:=s*sqr (a) ;

    a:=a+1;

    end;

    writeln (s) ;

    end.

    2) var a, i: integer;

    x: real;

    begin

    a:=0;

    readln (x) ;

    repeat

    a:=a+2;

    if power (a, 3) >x then writeln (a) ;

    until power (a, 3) >x;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «1 задача. Вычислить произведение квадратов n первых натуральных чисел. Для любого n введенного с клвитуры. 2 Найти первое чётное ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Язык - Pascal. даны натуральное число n и последовательностьa1, ..., an. Составьте программу, которая находит среднее арифметическое тех элементов последовательности, которые кратны 3 и не кратны 9
Ответы (1)
1. Даны целые числа b1, b2, ..., b10. Выяснить: а) верно ли, что сумма тех из них, которые больше 20, превышает 100; б) верно ли, что сумма тех из них, которые меньше 50, есть четное число.
Ответы (1)
Выполнить домашнее задание используя цикл while:  Ввести с клавиатуры число. Увеличивать переменную i до тех пор, пока она не станет равна введенному числу;  Программа рассчитывает сумму цифр введенного пользователем числа.
Ответы (1)
Помогите написать в паскале! Ввести три целых числа x, y, z. Если хотя бы одно из них четное, то первому четному числу присвоить значение произведения этих чисел.
Ответы (1)
Задача№1. Найти произведение цифр заданного трехзначного числа. Задача№2. Вычислить выражение y=cos (1) + cos (1/2) + cos (1/3) + ... + cos (1/n), где n вводить с клавиатуры. Задача№3. Даны действительные числа а1, а2 ... а n.
Ответы (1)