Задать вопрос
17 июля, 09:19

Дано натуральное число n. Определить сколько в числе нулей. Pascal ABC

+1
Ответы (1)
  1. 17 июля, 11:18
    0
    Var n, i:longint; begin read (n) ; i:=0; repeat if (n mod 10 = 0) then i:=i+1; n: = n div 10; until (n=0) ; writeln (i) ; End.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дано натуральное число n. Определить сколько в числе нулей. Pascal ABC ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Дано натуральное число N (N> 9). Определить количество нулей в цифровой записи числа, кроме нулей в младших разрядах. Пример. N=10 025 000. Количество нулей равно двум.
Ответы (1)
Дано натуральное число N. Напишите функцию (Pascal), определяющую количество нулей среди всех цифр числа N. Входные данные Задано единственное число N Выходные данные Необходимо вывести количество нулей среди всех цифр числа N.
Ответы (1)
1. Составьте программу в Pascal ABC. Известно, что X кг конфет стоит A рублей. Определить, сколько стоит 1 кг и Y кг этих же конфет. 2. Составьте программу в Pascal ABC. Дано двузначное число. Найти сумму и произведение его цифр. 3.
Ответы (1)
1. Дано натуральное число. Найти первую цифру данного числа. 2. Дано натуральное число. Определить количество троек в нем. 3. Дано натуральное число. Определить количество четных цифр в нем. Все это при помощи цикла:while
Ответы (1)
1) Вычислить длину окружности и площадь круга одного и того же заданного радиуса R. Pascal (желательно с блок-схемой) 2) Найти сумму членов арифметической прогрессии, если известны её первый член, знаменатель и число членов прогрессии Pascal
Ответы (1)