Задать вопрос
17 июля, 07:23

Сделать из числа 123 число 312 в pascal

+5
Ответы (1)
  1. 17 июля, 08:15
    0
    ИЗИ

    var

    N1, N2 : Word;

    begin

    Write ('Введите число: ') ; ReadLn (N1) ;

    N2 : = 0; while N1 > 0 do begin N2 : = N2 * 10 + N1 mod 10; N1 : = N1 div 10; end;

    WriteLn ('Перевёрнутый результат: ', N2) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Сделать из числа 123 число 312 в pascal ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Как описывают переменные в Pascal? Какие стандартные числовые типы языка Pascal вам известны? Что вам известно о соответствии типов переменных в языке Pascal? Какие арифметические операции можно выполнять в Pascal?
Ответы (1)
1) Вычислить длину окружности и площадь круга одного и того же заданного радиуса R. Pascal (желательно с блок-схемой) 2) Найти сумму членов арифметической прогрессии, если известны её первый член, знаменатель и число членов прогрессии Pascal
Ответы (1)
Pascal a+b=c = abc примеры 099 - 0+9 = 9 199100 - 1+99 = 100 12345168 - 123+45=168 как сделать это в Pascal (код)
Ответы (1)
Вывести трехзначное (123) число в обратном порядке. pascal Например 123 Вывести 321
Ответы (1)
1. Составьте программу в Pascal ABC. Известно, что X кг конфет стоит A рублей. Определить, сколько стоит 1 кг и Y кг этих же конфет. 2. Составьте программу в Pascal ABC. Дано двузначное число. Найти сумму и произведение его цифр. 3.
Ответы (1)