Задать вопрос
16 сентября, 09:26

В двумерном массиве выше побочной диагонали надо найти минимальное число на языке Паскаль

+3
Ответы (1)
  1. 16 сентября, 12:26
    0
    Var A:array[1 ... 100,1 ... 100] of Integer;

    min, i, j, N:integer;

    begin

    Readln (N) ;

    For i:=1 to N do

    For j:=1 to N do

    A[i, j]:=Random (0,100) ;

    For i:=1 to N do

    begin

    For j:=1 to N do

    Write (A[i, j],' ') ;

    Writeln;

    end;

    min:=A[1,1];

    For i:=1 to N do

    For j:=N-i downto 1 do

    If A[i, j]
    min:=A[i, j];

    Writeln ('min = ', min) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «В двумерном массиве выше побочной диагонали надо найти минимальное число на языке Паскаль ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Паскаль 1. В двумерном массиве вычислить A (4,4) найти наибольший элемент, лежащий на главной диагонали. 2. Дан массив A (5,5). Для данного натурального M найти сумму тех элементов массива, сумма индексов которых равна M (М - вводится с клавиатуры).
Ответы (1)
Перед вами часть кода программы на языке Pascal. sum:=0; for i:=1 to n do for j:=1 to n do if (i
Ответы (1)
Паскаль. В двумерном массиве найти сумму элементов главной и побочной диагонали, элемент, находящийся в центре должен быть посчитан лишь один раз. Нужно написать программу.
Ответы (1)
В двумерном массиве найти в двумерном массиве найти минимальные и максимальные элементы и вычислить их сумму произведение и разность (Составить программу)
Ответы (1)
В двумерном массиве 7 Х7 произвольных целых чисел вычислить сумму элементов, расположенных слева от побочной диагонали. Определить минимальный элемент главной диагонали (значение и координаты)
Ответы (1)