Задать вопрос
16 сентября, 08:49

Напишите программу в Pascal ABC в которой нужно определить номера строк двухмерного массива 5 х3, содержащего только положительные элементы

+4
Ответы (1)
  1. 16 сентября, 10:50
    0
    Const n=5

    var

    a:array [1 ... n, 1 ... n] of integer;

    d:array [1 ... n] of integer;

    i, j:integer;

    begin

    for i:=1 to 5 do

    for j:=1 to 3 do

    readln (a[i, j]) ;

    for i:=1 to 5 do begin

    for j:=1 to 3 do begin

    if a[i, j]>0 then

    d[i]:=d[i]+1;

    end;

    if d[i]=3 then

    d[i]:=i

    else

    d[i]:=0;

    end;

    for i:=1 to 5 do

    if d[i]>0 then

    writeln (d[i]) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Напишите программу в Pascal ABC в которой нужно определить номера строк двухмерного массива 5 х3, содержащего только положительные элементы ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Возвести в квадрат все элементы массива A. Размер массива и значения элементов массива - произвольные. 2. Увеличить на 4 все элементы в первой половине массива A (считать, что в массиве чётное число элементов).
Ответы (1)
Все задачи делаются в Паскале! 1) Увеличить все элементы массива A на 1. 2) Умножить все элементы массива A на 2. 3) Возвести в квадрат все элементы массива A.
Ответы (1)
Pascal ABC Напишите программу, которая находит три наименьших элемента массива и переставляет их в начало массива. Остальные элементы должны следовать далее в том же порядке. Входные данные Первая строка содержит размер массива N.
Ответы (1)
В записи m[7]=9 m обозначает 1) имя массива 2) имя элемента массива 3) номер элемента массива 4) значение элемента массива в записи m[7]=
Ответы (1)
Помогите с информатикой 1. Что такое массив? 2. Что такое элемент массива? 3. Что такое индекс массива? 4. Что такое размерность массива? 5. Зачем нужны массивы? 6. Как можно обратиться к ячейке массива? 7. Какого типа могут быль элементы массива? 8.
Ответы (1)