Задать вопрос
8 мая, 13:48

Напишите двумерный массив с помощью функции и процедуры!

+1
Ответы (1)
  1. 8 мая, 16:52
    0
    Const N=5; M=6;

    var A:array[1 ... 100,1 ... 100] of Integer;

    B:integer;

    function massive () : integer;

    begin

    B:=random (-100,100) ;

    Result:=B;

    end;

    procedure input (i, j:integer) ;

    begin

    For i:=1 to N do

    For j:=1 to M do

    A[i, j]:=massive () ;

    end;

    procedure

    output (i, j:integer) ;

    begin

    For i:=1 to N do

    begin

    For j:=1 to M do

    Write (A[i, j],' ') ;

    Writeln;

    end;

    end;

    begin

    input (1,1) ;

    output (1,1) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Напишите двумерный массив с помощью функции и процедуры! ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
2. Задать двумерный массив (4 х4) случайными значениями от 12 до 18 включительно. Вывести сумму значений элементов каждого столбца матрицы. 3. Задать двумерный массив (7 х7) случайными значениями от 12 до 18 включительно.
Ответы (1)
Написать программу с использованием процедуры или функции. Объявлен массив целых чисел. m размером 5 х10. Заполнить массив числами из промежутка [-20,20]. Каждый элемент массива заменить его кубом. Исходный и измененный массив вывести на экран.
Ответы (1)
Хотя бы 3-4 задачи! 1) Дан одномерный целочисленный массив размерностью N. Найдите количество элементов, которые кратны 3 (5). 2) Дан одномерный целочисленный массив А, состоящий из N элементов. Найти сумму всех четных элементов массива.
Ответы (1)
1. задать двумерный массив (5 х5) случайными значениями от 5 до 10 включительно. В каждой строке найди количество элементов, значения которых >7. 2. задать двумерный массив (3 х3) с клавиатуры, поменять значения элементов 1 строки с последней.
Ответы (1)
Составить программу на Паскале. Двумерный массив А[4; 4] заполнен случайными числами. Посчитать сумму элементов каждой строки с помощью процедуры.
Ответы (1)