Задать вопрос
25 июня, 16:12

1. задать двумерный массив (5 х5) случайными значениями от 5 до 10 включительно. В каждой строке найди количество элементов, значения которых >7.

2. задать двумерный массив (3 х3) с клавиатуры, поменять значения элементов 1 строки с последней.

+2
Ответы (1)
  1. 25 июня, 16:41
    0
    1.

    uses crt;

    const n=5;

    var i, j, ans:integer;

    a:array[1 ... n, 1 ... n] of integer;

    begin

    randomize;

    for i:=1 to n do

    begin

    for j:=1 to n do

    begin

    a[i, j]:=random (5,10) ;

    write (a[i, j],' ') ;

    end;

    writeln () ;

    end;

    for i:=1 to n do

    begin

    ans:=0;

    for j:=1 to n do

    begin

    if a[i, j]>7 then

    ans:=ans+1;

    end;

    writeln ('In ', i,': ', ans) ;

    end;

    end.

    2.

    uses crt;

    const n=3;

    var i, j, t:integer;

    a:array[1 ... n, 1 ... n] of integer;

    begin

    writeln ('Input array:') ;

    for i:=1 to n do

    for j:=1 to n do

    read (a[i, j]) ;

    for j:=1 to n do

    begin

    t:=a[1, j];

    a[1, j]:=a[3, j];

    a[3, j]:=t;

    end;

    for i:=1 to n do

    begin

    for j:=1 to n do

    write (a[i, j],' ') ;

    writeln () ;

    end;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «1. задать двумерный массив (5 х5) случайными значениями от 5 до 10 включительно. В каждой строке найди количество элементов, значения ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
2. Задать двумерный массив (4 х4) случайными значениями от 12 до 18 включительно. Вывести сумму значений элементов каждого столбца матрицы. 3. Задать двумерный массив (7 х7) случайными значениями от 12 до 18 включительно.
Ответы (1)
Решить не могу задачи по информатике: 1. Составьте программу ввода элементов массива h [1 ... 8] с клавиатуры и вывода на экран элементов с отрицательными значениями. 2. Составьте программу, которая заполняет массив h [1 ...
Ответы (1)
Решите задачи: 1) Составьте программу ввода элементов массива [1 ... 8] с клавиатуры и вывода на экран элементов массива с отрицательными значениями. 2) Составьте программу, которая заполняет массив а [1 ...
Ответы (1)
Задать двумерный массив (6 6) случайными значениями от 15 до 20 включительно. Вывести сумму значений элементов каждой строки матрицы
Ответы (2)
Хотя бы 3-4 задачи! 1) Дан одномерный целочисленный массив размерностью N. Найдите количество элементов, которые кратны 3 (5). 2) Дан одномерный целочисленный массив А, состоящий из N элементов. Найти сумму всех четных элементов массива.
Ответы (1)