Задать вопрос
27 сентября, 01:00

Составить программу на Паскале. Двумерный массив А[4; 4] заполнен случайными числами. Посчитать сумму элементов каждой строки с помощью процедуры.

+1
Ответы (1)
  1. 27 сентября, 04:08
    0
    Const n=4;

    var

    a:array[1 ... n, 1 ... n] of integer;

    i, j, s:integer;

    procedure sum (k:integer; var s:integer) ;

    var j:integer;

    begin

    s:=0;

    for j:=1 to n do s:=s+a[k, j];

    end;

    begin

    Randomize;

    writeln ('Исходный массив:') ;

    for i:=1 to n do

    begin

    for j:=1 to n do

    begin

    a[i, j]:=random (100) ;

    write (a[i, j]:4) ;

    end;

    writeln;

    end;

    for i:=1 to n do

    begin

    write (i,'-я строка: ') ;

    sum (i, s) ;

    writeln ('s = ', s) ;

    end;

    end.

    Пример:

    Исходный массив:

    60 78 10 51

    65 90 65 24

    35 97 6 91

    10 95 35 15

    1-я строка: s = 199

    2-я строка: s = 244

    3-я строка: s = 229

    4-я строка: s = 155
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составить программу на Паскале. Двумерный массив А[4; 4] заполнен случайными числами. Посчитать сумму элементов каждой строки с помощью ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
2. Задать двумерный массив (4 х4) случайными значениями от 12 до 18 включительно. Вывести сумму значений элементов каждого столбца матрицы. 3. Задать двумерный массив (7 х7) случайными значениями от 12 до 18 включительно.
Ответы (1)
Хотя бы 3-4 задачи! 1) Дан одномерный целочисленный массив размерностью N. Найдите количество элементов, которые кратны 3 (5). 2) Дан одномерный целочисленный массив А, состоящий из N элементов. Найти сумму всех четных элементов массива.
Ответы (1)
Тема одномерные массивы Написать программу в паскале: 1. Массив на 15 значений заполнен случайными числами посчитать количество нечетных значений 2.
Ответы (1)
Написать программу в Паскале! Указание: Заполнить двумерный числовой массив И (8,8) случайными целыми числами в интервале [-60,60]. Написать единую программу для всех задач, ответ каждой задачи выводить с новой строки.
Ответы (1)
Решить не могу задачи по информатике: 1. Составьте программу ввода элементов массива h [1 ... 8] с клавиатуры и вывода на экран элементов с отрицательными значениями. 2. Составьте программу, которая заполняет массив h [1 ...
Ответы (1)