Задать вопрос
23 сентября, 04:50

Написать программу в Паскале!

Указание: Заполнить двумерный числовой массив И (8,8) случайными целыми числами в интервале [-60,60]. Написать единую программу для всех задач, ответ каждой задачи выводить с новой строки.

Задача 1: Найдите среднее арифметическое отрицательных элементов 3 строки.

Задача 2: Обнулите элементы, имеющие четное значение и стоящие на побочной диагонали.

Задача 3: Создайте новый одномерный массив из элементов, имеющих значение больше - 5.

Задача 4: Определите максимальный элемент массива в первом столбике.

Задача 5: Вычислить сумму элементов в каждой строке массива.

+1
Ответы (1)
  1. 23 сентября, 07:47
    0
    Const n=3;

    var a:array[1 ... n, 1 ... n] of integer;

    ss:array[1 ... n] of integer;

    i, j, s, k, max:integer; sr:real;

    begin

    writeln ('Исходный массив: ') ;

    for i:=1 to n do

    for j:=1 to n do a[i, j]:=random (121) - 60;

    for i:=1 to n do begin

    for j:=1 to n do write (a[i, j]:5) ;

    writeln;

    end;

    for i:=1 to n do

    for j:=1 to n do

    if (i=3) and (a[i, j]<0) then begin

    s:=s+a[i, j];

    k:=k+1;

    end;

    sr:=s/k;

    writeln ('Ср. арифм. отрицательных элементов 3 строки: ', sr) ;

    writeln ('После обнуления: ') ;

    for i:=1 to n do

    for j:=1 to n do

    if (j=n-i+1) and (a[i, j] mod 2=0) then a[i, j]:=0;

    for i:=1 to n do begin

    for j:=1 to n do write (a[i, j]:5) ;

    writeln;

    end;

    writeln ('Одномерный массив из элементов, имеющих значение больше - 5: ') ;

    for i:=1 to n do

    for j:=1 to n do

    if (a[i, j]>-5) then write (a[i, j],' ') ;

    writeln;

    writeln ('Максимальный элемент массива в 1 стоблце: ') ;

    max:=a[1,1];

    for i:=1 to n do

    for j:=1 to n do

    if a[i, 1]>max then max:=a[i, 1];

    write (max) ;

    writeln;

    writeln ('Сумма элементов в каждой строке массива: ') ;

    for i:=1 to n do

    ss[i]:=0;

    for i:=1 to n do

    for j:=1 to n do

    ss[i]:=ss[i]+a[i, j];

    for i:=1 to n do write (ss[i]:5) ;

    writeln;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Написать программу в Паскале! Указание: Заполнить двумерный числовой массив И (8,8) случайными целыми числами в интервале [-60,60]. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Хотя бы 3-4 задачи! 1) Дан одномерный целочисленный массив размерностью N. Найдите количество элементов, которые кратны 3 (5). 2) Дан одномерный целочисленный массив А, состоящий из N элементов. Найти сумму всех четных элементов массива.
Ответы (1)
1 задача: Массив Z (20) заполнить целыми случайными числами в диапазоне от - 20 до 20. Вычислить CP - среднее арифметическое положительных элементов и CN - среднее арифметическое отрицательных элементов массива Z.
Ответы (1)
С # 1. Создайте одномерный массив с 31 элементов, которые заполните случайными целыми числами от 11 до 100-11. Выведите значения элементов массива в строку, разделив их пробелами, 11 нечетное число.
Ответы (1)
Во имя радостных мессий, помогите хоть одну задачку. Не шарю ( Дан массив из 15 элементов. Необходимо заполнить его с помощью оператора присваивания (случайными числами), вывести все элементы в строку, а затем вывести произведение всех элементов
Ответы (1)
Заполнить матрицу А 5 х5 случайными числами до 20 и далее выполнить задание: 1. Найти максимальный элемент на побочной диагонали; 2. Составить одномерный массив В из минимальных элементов каждой строки; 3.
Ответы (1)