Задать вопрос
24 ноября, 13:17

Написать программу с использованием процедуры или функции. Объявлен массив целых чисел. m размером 5 х10. Заполнить массив числами из промежутка [-20,20]. Каждый элемент массива заменить его кубом. Исходный и измененный массив вывести на экран. Возведение в 3 степень организовать с помощью функции или процедуры

+2
Ответы (1)
  1. 24 ноября, 16:00
    0
    type

    Mas = array [1 ... 5, 1 ... 10] of integer; / / Объявляем тип массива

    var

    m: Mas; / / Переменная типа массива

    i, j: integer; / / Переменные для цикла

    procedure CubeMas (var m: Mas) ; / / Процедура возведения в куб

    var

    i, j: integer; / / Локальные переменные цикла в процедуре

    begin

    write ('Измененный массив: ') ;

    for i: = 1 to 5 do

    for j: = 1 to 10 do

    begin

    m[i, j]: = sqr (m[i, j]) * m[i, j]; / / Возводим элемент массива в куб

    write ('m[', i, ', ', j, '] = ', m[i, j], ' ') ; / / Печатаем элемент массива

    end; / / Конец цикла

    writeln; / / Перевод на новую строку

    end; / / Конец процедуры

    begin

    write ('Исходный массив: ') ;

    for i: = 1 to 5 do

    for j: = 1 to 10 do

    begin

    m[i, j]: = random (40) - 20; {Присваиваем элементу массива случайное значение из промежутка [-20, 20] }

    write ('m[', i, ', ', j, '] = ', m[i, j], ' ') ; / / Печатаем элемент массива

    end; / / Конец цикла

    writeln; / / Перевод на новую строку

    CubeMas (m) ; / / Вызываем процедуру возведения в куб

    end. / / Конец программы
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Написать программу с использованием процедуры или функции. Объявлен массив целых чисел. m размером 5 х10. Заполнить массив числами из ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1) Заполнить массив размером N целыми числами последовательно от 1 до N. Вывести его на экран. Найти сумму элементов массива и вывести ее на экран. 2) Заполнить массив размером N целыми числами последовательно от N до 1. Вывести его на экран.
Ответы (1)
1. Дан одномерный массив размерностью 10, заполненный целыми числами, введенными с клавиатуры, и величина N. Отрицательные элементы заменить на N. Измененный массив вывести на экран одной строкой. 2.
Ответы (1)
1. Массив и 4 целых чисел вводится с клавиатуры. Найти и вывести произведение элементов массива. 2. Массив из 6 отрицательных и положительных целых чисел вводится в области описания констант. Найти сумму положительных элементов массива. 3.
Ответы (1)
Дан массив А из N целочисленных элементов. 1) Заполнить массив А целыми числами в интервале[1,100] и вывести на экран. Найти максимальный четный элемент и вывести его на экран.
Ответы (1)
Хотя бы 3-4 задачи! 1) Дан одномерный целочисленный массив размерностью N. Найдите количество элементов, которые кратны 3 (5). 2) Дан одномерный целочисленный массив А, состоящий из N элементов. Найти сумму всех четных элементов массива.
Ответы (1)