Задать вопрос
22 апреля, 11:18

Составить алгоритм и написать программу вычисления площади геометрической фигуры с использованием условного оператора if по одной из формул: S=п*r; S=a*b

+4
Ответы (1)
  1. 22 апреля, 13:52
    0
    var

    s, r, a, b:real;

    k:byte;

    begin

    repeat

    write ('1 - S kruga; 2 - S pryamougolnika: ') ; readln (k) ;

    until (k=1) or (k=2) ;

    if k=1 then begin

    write ('Radius: ') ; readln (r) ;

    s:=pi*r;

    writeln ('S = ', s:0:5) ;

    end else begin

    write ('A = ') ; readln (a) ;

    write ('B = ') ; readln (b) ;

    s:=a*b;

    writeln ('S = ', s:0:4) ;

    end;

    readln;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составить алгоритм и написать программу вычисления площади геометрической фигуры с использованием условного оператора if по одной из ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Напишите программу вычисления расстояния между двумя точками плоскости. 2. Напишите программу вычисления площади боковой поверхности куба. 3. Напишите программу вычисления площади и гипотенузы прямого треугольника, если известны его катеты. 4.
Ответы (1)
1) Вывести Чётные числа с 18 до 62 с использованием оператора цикла "for" 2) Вывести нечётные числа в обратном порядке с 31 до 1 с использованием оператора цикла "for".
Ответы (1)
Вычислить произведение четырех натур. чисел, используя только операцию сложения. (Язык пр:pascal) 1) Написать программу (обычную) 2) Написать программу с использованием процедуры 3) Написать программу с исп. функции 4) Написать программу с исп.
Ответы (1)
Используя язык программирования Паскаль выполнить задание: 1. Составить программу для вычисления y=38x+231. 2. Составить программу для вычисления M=7x+6y+276. 3. Составить программу для вычисления N=4a2+2xa+8y.
Ответы (1)
1. Cоставить программу вычисления площади круга: S = п (пи) * R^2 2. Cоставить программу вычисления площади треугольника: S=1/2*A*H 1) Выделить целую часть результата.
Ответы (1)