Задать вопрос
20 марта, 03:32

Вывести все значения элементов заданной числовой последовательности.

Входные данные: Выходные данные:

Во входном потоке в первой строке записано единственное целое число N (0 < N < = 100) - число элементов числовой последовательности;

Во второй строке перечислены вещественные значения элементов числовой последовательности (через пробел). Значения элементов по модулю не превышают 1000.

В выходной поток вывести значения элементов числовой последовательности в столбик с точностью три знака после запятой.

Пример входного файла (input. txt) :

10

43.4 564.54 32.435 76.654 342.6456 76 ...

+5
Ответы (1)
  1. 20 марта, 03:47
    0
    Var

    a:array[1 ... 1000] of extended;

    i, n:longint;

    begin

    readln (n) ;

    for i:=1 to n do read (a[i]) ;

    writeln;

    for i:=1 to n do writeln (a[i]:0:3) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Вывести все значения элементов заданной числовой последовательности. Входные данные: Выходные данные: Во входном потоке в первой строке ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Решать в Pascal Найти наибольший элемент заданной целочисленной числовой последовательности. Входные данные: Во входном потоке в первой строке задано натуральное число N (N < = 1000) - количество элементов числовой последовательности.
Ответы (1)
Напишите программу, которая сортирует массив целых чисел в порядке возрастания (неубывания). Размер массива заранее неизвестен. Исходные данные записаны в файл input. txt, отсортированный массив нужно вывести в файл output. txt.
Ответы (1)
Напишите программу, которая сортирует массив ненулевых целых чисел в порядке возрастания (неубывания). Размер массива заранее неизвестен. Исходные данные записаны в файл input. txt, отсортированный массив нужно вывести в файл output. txt.
Ответы (1)
1. Задан полный путь к файлу C:/Мои документы/доклад. txt Каково полное имя файла? а) C: / Мои документы/доклад. txt б) Мои документы/доклад. txt в) доклад г) доклад. txt 2. Задан полный путь к файлу C:/Мои документы/доклад.
Ответы (2)
За день машина проезжает n километров. Сколько дней нужно, чтобы проехать маршрут длиной m километров? Входные данные: Во входном потоке в первой строке через пробел заданы целые значения N и M, значения которых не превышает 30000.
Ответы (1)