Задать вопрос
18 января, 10:29

Решать в Pascal

Найти наибольший элемент заданной целочисленной числовой последовательности.

Входные данные: Во входном потоке в первой строке задано натуральное число N (N < = 1000) - количество элементов числовой последовательности. Во второй строке через пробел перечислены значения элементов последовательности Ai (-32000 < = Ai < = 32000).

Выходные данные: В выходной поток вывести единственное целое число.

Пример входного файла (input. txt) : 8

100 10 - 10 - 100 300 32000 20000 - 30000

Пример выходного файла (output. txt) : 32000

Мое решение (ошибку скажите) :

var a, b, max, i:longint;

begin

read (a) ;

for i:=1 to a do begin

read (b) ;

if b>=max then max:=b;

end;

write (max) ;

end.

+5
Ответы (1)
  1. 18 января, 11:16
    0
    Ошибка заключается в том, что переменную max нужно инициализировать прежде, чем будет осуществлен вход в цикл.

    var a, b, max, i : longint;

    begin

    read (a) ;

    max : = - 32001;

    for i:=1 to a do begin

    read (b) ;

    if b > = max then

    max:=b;

    end;

    write (max) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Решать в Pascal Найти наибольший элемент заданной целочисленной числовой последовательности. Входные данные: Во входном потоке в первой ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Вывести все значения элементов заданной числовой последовательности. Входные данные: Выходные данные: Во входном потоке в первой строке записано единственное целое число N (0 < N < = 100) - число элементов числовой последовательности;
Ответы (1)
Напишите программу, которая сортирует массив целых чисел в порядке возрастания (неубывания). Размер массива заранее неизвестен. Исходные данные записаны в файл input. txt, отсортированный массив нужно вывести в файл output. txt.
Ответы (1)
Помогите отредактировать программу - Паскаль. Где-то ошибка. Необходимо удалить первый кратный 3 элемент массива. program udalenie; var i, n, k:integer; a:array[1 ... 1000] of integer; begin assign (input,'input. txt') ; assign (output,'output.
Ответы (1)
Напишите программу, которая сортирует массив ненулевых целых чисел в порядке возрастания (неубывания). Размер массива заранее неизвестен. Исходные данные записаны в файл input. txt, отсортированный массив нужно вывести в файл output. txt.
Ответы (1)
Найти сумму чисел в текстовом документе. Почему пишет неизвестный идентификатор. var a, b:integer; begin assign (input,'input. txt') ; reset (input) ; assign (output,'output.
Ответы (1)