Задать вопрос
29 ноября, 16:18

Как написать программу в Паскале, чтобы 2 рандомных числа не повторялось?

+5
Ответы (2)
  1. 29 ноября, 18:40
    0
    Var a, b, n:integer;

    begin

    n:=10;

    Randomize;

    a:=random (n) + 1;

    b:=random (n) + 1;

    while b=a do b:=random (n) + 1;

    writeln ('a = ', a,' b = ', b) ;

    end.

    Пример:

    a = 8 b = 4
  2. 29 ноября, 19:23
    0
    {

    Думаю, это должно работать

    Важно, что во второй раз выбор происходит уже среди n-1 вариантов

    }

    const n = 10;

    var i, j: integer;

    begin

    i : = 1 + random (n) ;

    j : = 1 + random (n-1) ;

    if j > = i then j : = j + 1;

    write (i,' ', j)

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Как написать программу в Паскале, чтобы 2 рандомных числа не повторялось? ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Напишите программу по выдаче рандомных чисел, содержащих от 1 до 5 знаков, состоящих из чисел от 1 до 12, так чтобы: За цифрой 1 могли следовать только цифры 4, 5, 7, 9, 10 За цифрой 2 - только 5, 6, 8, 10, 11 За цифрой 3 - только 6, 7, 9, 11, 12 За
Ответы (1)
Вычислить произведение четырех натур. чисел, используя только операцию сложения. (Язык пр:pascal) 1) Написать программу (обычную) 2) Написать программу с использованием процедуры 3) Написать программу с исп. функции 4) Написать программу с исп.
Ответы (1)
Зачетная работа по информатике. 1. Написать программу вычисления площади прямоугольника (на паскале). 2. Написать программу вычесления ускорения тела (на паскале).
Ответы (1)
Помогите написать программу в паскале! Написать программу в паскале: В одномерном массиве из 10 целых чисел вычислить сумму четных чисел ...
Ответы (1)
Паскаль. 1. Вывести в столбик все двузначные числа. (1 цикл, 1 переменная) 2. Из тех же чисел вывести только те, что заканчиваются на 5. 3. Вывести в ряд 15 рандомных чисел от 10 до 30.
Ответы (1)