Задать вопрос
13 июля, 05:53

Паскаль.

1. Вывести в столбик все двузначные числа. (1 цикл, 1 переменная)

2. Из тех же чисел вывести только те, что заканчиваются на 5.

3. Вывести в ряд 15 рандомных чисел от 10 до 30.

+5
Ответы (1)
  1. 13 июля, 07:34
    0
    1.

    var i:integer;

    begin

    for i:=10 to 99 do writeln (i) ;

    end.

    Результат:

    10

    11

    12

    ...

    98

    99

    2.

    var i:integer;

    begin

    for i:=10 to 99 do

    if i mod 10=5 then writeln (i) ;

    end.

    Результат:

    15

    25

    ...

    95

    3.

    var i:integer;

    begin

    for i:=1 to 15 do

    write (random (21) + 10,' ') ;

    end.

    Пример:

    25 19 12 11 25 27 30 19 21 19 15 10 14 22 22
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Паскаль. 1. Вывести в столбик все двузначные числа. (1 цикл, 1 переменная) 2. Из тех же чисел вывести только те, что заканчиваются на 5. 3. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Ввести слово и число раз (Ввод; паскаль, 3). Вывести это слово так: паскаль паскаль паскаль паскаль паскаль паскаль
Ответы (1)
Напишите программу по выдаче рандомных чисел, содержащих от 1 до 5 знаков, состоящих из чисел от 1 до 12, так чтобы: За цифрой 1 могли следовать только цифры 4, 5, 7, 9, 10 За цифрой 2 - только 5, 6, 8, 10, 11 За цифрой 3 - только 6, 7, 9, 11, 12 За
Ответы (1)
Паскаль. 1. вывести на экран все четные числа от 1 до n. 2. вывести на экран все трехзначные числа. 3. вывести на экран четырехзначные числа оканчивающийся на 7. 4. вывести на экран все трехзначные и двухзначные числа сумма цифр которых равна девяти.
Ответы (1)
В каком типе цикла тело цикла выполняется пока условие ложно? А) цикл со счетчиком Б) цикл с постусловием В) цикл с предусловием Г) цикл с рекурсией
Ответы (1)
Какое значение будет иметь переменная G в выражении G: = 42/2 + 4? А. 1; Б. 7; В. 21; Г. 25. 5. Какое значение будет иметь переменная M в результате выполнения М: = 20/10 + 10• (2•4/2) ? А. 82; Б. 42; В. 80; Г. 40. 6.
Ответы (1)