Задать вопрос
7 декабря, 22:14

Паскаль. Составьте блок схему и программу определения минимума из трёх чисел не используя логических операций. Программа должна иметь дружественный интерфейс.

+5
Ответы (1)
  1. 8 декабря, 01:06
    0
    Function Min (aa, bb : Integer) : Integer;

    Begin

    Min: = (aa+bb) div 2 - abs (aa-bb) div 2;

    end;

    Var A, B, C : Integer;

    Begin

    Write ('Введите три числа: ') ; Readln (A, B, C) ;

    Writeln ('Минимальное число: ', Min (A, Min (B, C))) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Паскаль. Составьте блок схему и программу определения минимума из трёх чисел не используя логических операций. Программа должна иметь ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Составьте на Паскале программу определения минимума из трёх чисел с использованием логических операций. Программа должна иметь дружественный интерфейс.
Ответы (1)
Составить на Паскале программу определения минимума из трёх чисел без использования логических операций. Программа должна иметь дружественный интерфейс (ввод данных осуществляться в режиме диалога).
Ответы (1)
Что обеспечивает взаимодействие между устройствами компьютера? 1) графический интерфейс 2) пользовательский интерфейс 3) командный интерфейс 4) аппаратный интерфейс Выбирите один вариант ответа;)
Ответы (2)
Составьте программу, выполняющую умножение двух чисел, введеных с клавиатуры. Программа должна иметь дружественный интерфейс
Ответы (1)
Треугольник задан длинами сторон А, В, С. Написать программу, определяющую, существует ли данный треугольник. Для решения этой задачи использовать сложные логические условия. Программа должна иметь дружественный интерфейс.
Ответы (1)