Задать вопрос
11 декабря, 21:58

Зaполнить мaccив Х[1 ... 39] целыми cлучaйными чиcлaми из [-15; 37] и вывеcти его нa экрaн, выделив цветом чиcлa, меньше 30. Cколько тaких чиcел? Провеcти cортировку этого мaccивa по возрacтaнию и вывеcти результaт нa экрaн. Cколько в этом мaccиве чиcел, нaчинaющихcя c двойки

+2
Ответы (1)
  1. 11 декабря, 23:55
    0
    Uses Crt;

    Const

    N = 39;

    Var

    X:array[1 ... N] of integer;

    i, j, k:integer;

    Begin

    Randomize;

    ClrScr;

    k:=0;

    WriteLn ('Исходный массив: ') ;

    For i: = 1 to N do

    Begin

    X[i]:=random (53) - 15;

    if X[i]<30 then

    Begin

    TextColor (12) ;

    k:=k+1;

    End

    else TextColor (7) ;

    Write (X[i],' ') ;

    End;

    WriteLn;

    WriteLn;

    TextColor (7) ;

    WriteLn ('Числа, меня тридцати: ', k) ;

    WriteLn;

    WriteLn ('Упорядоченный массив: ') ;

    For i: = 1 to N do

    For j: = 1 to N-1 do

    if X[j]>X[j+1] then

    Begin

    k:=X[j+1];

    X[j+1]:=X[j];

    X[j]:=k;

    End;

    k:=0;

    For i: = 1 to N do

    Begin

    Write (X[i],' ') ;

    j:=X[i];

    While j div 10 0 do

    j:=j div 10;

    if (j = 2) or (j = - 2) then

    k:=k+1;

    End;

    WriteLn;

    WriteLn;

    WriteLn ('Числа, начинающиеся с двойки: ', k) ;

    ReadLn;

    End.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Зaполнить мaccив Х[1 ... 39] целыми cлучaйными чиcлaми из [-15; 37] и вывеcти его нa экрaн, выделив цветом чиcлa, меньше 30. Cколько тaких ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
На световой панели в ряд расположены 6 лампочек. Каждая лампочка может гореть красным цветом, желтым цветом или зеленым цветом. Сколько различных сигналов можно передать с помощью панели (все лампочки должны гореть, порядок цветов имеет значение) ?
Ответы (1)
Петя заметил, что сегодня удивительный день: на его флешке все файлы различного объема и размер в килобайтах каждого файла является точной степенью двойки, а всего занято 2017 килобайт.
Ответы (1)
1) Заполнить массив размером N целыми числами последовательно от 1 до N. Вывести его на экран. Найти сумму элементов массива и вывести ее на экран. 2) Заполнить массив размером N целыми числами последовательно от N до 1. Вывести его на экран.
Ответы (1)
Создайте программу последуещему сценарию: У пользователя запрашивается длина стороны. На холсте случайным цветом рисуется пятнадцать-угольник с заданной длинной стороны и заливается случайным цветом. У пользователя запрашивается количество фигурок.
Ответы (1)
А) Составьте программу, которая заполняет массив В[1 ... 11] случайными целыми числами в диапазоне от - 5 до 5 и преобразовывает его, заменяя элементы кратные 5 на 5, а остальные увеличивая в 5 раз.
Ответы (1)