Задать вопрос
11 апреля, 20:04

Ввести одно число, указывающие количество вводимых двузначных чисел. Из введенных двузначных чисел найти количество четных.

+5
Ответы (1)
  1. 11 апреля, 22:11
    0
    Var n, a, i, nn:integer;

    begin

    write ('Количество двузначных чисел: ') ;

    readln (n) ;

    for i:=1 to n do begin

    repeat

    write ('Введите ', i,' число') ; readln (a) ;

    until (a>9) and (a<100) ;

    if a mod 2 = 0 then nn:=nn+1;

    end;

    writeln ('Количество четных двухзначных = ', nn) ;

    end.

    Тестовое решение:

    Введите 1 число1

    Введите 1 число23

    Введите 2 число44

    Введите 3 число3

    Введите 3 число32

    Введите 4 число45

    Введите 5 число56

    Количество четных двухзначных = 3
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Ввести одно число, указывающие количество вводимых двузначных чисел. Из введенных двузначных чисел найти количество четных. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Написать программу, вычисляющую сумму отрицательных чисел, кратных 5, среди пяти, вводимых с клавиатуры. 2. Написать программу, вычисляющую произведение чисел, оканчивающихся цифрами 2 и 4, среди пяти, вводимых с клавиатуры. 3.
Ответы (1)
Напишите программу, которая для последовательности целых чисел определяет количество четных чисел. Программа получает на вход количество чисел в последоввтельности, а затем сами числа. Количество чисел не привышает 1000.
Ответы (1)
Напишите программу, которая находит сумму четных чисел, больших 5, в последовательности целых чисел. Программа получает на выход целые числа, количество введенных чисел неизвестно, последовательность заканчивается числом 0 (признак окончания ввода,
Ответы (1)
С клавиатуры вводятся 3 числа. Найти количество и сумму четных чисел среди них. Если среди введенных четных нет, то вывести соответствующее сообщение.
Ответы (1)
Задачи: 1) Найти насколько (количество) двузначных чисел кратных 3 больше чем двузначных чисел кратных 5.
Ответы (1)