Задать вопрос
11 апреля, 18:21

Подсчитать количество отрицательных, нулевых и положительных элементов массива с номерами позиций, кратных двум, начиная с первого. Размер носить массива произвольнаЯ

+2
Ответы (1)
  1. 11 апреля, 20:56
    0
    Var

    a : array [1 ... 1000] of integer;

    i, n, z, p, m : integer;

    begin

    i : = 0;

    while not eoln do

    begin

    read (z) ;

    inc (i) ;

    a[i] : = z;

    end;

    m: = i; n:=0; z:=0; p: = 0;

    for i : = 1 to m do

    if i mod 2 = 0 then

    begin

    if a[i] < = then inc (n)

    else if a[i] > 0 then inc (p)

    else inc (z) ;

    end;

    writeln (n, ' ', z, ' ', p) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Подсчитать количество отрицательных, нулевых и положительных элементов массива с номерами позиций, кратных двум, начиная с первого. Размер ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Дан целочисленный массив из 7 элементов: 1) подсчитать произведение элементов массива кратных 5 и кратных 3. 2) подсчитать среднее значение четных элементов массива.
Ответы (1)
1. Возвести в квадрат все элементы массива A. Размер массива и значения элементов массива - произвольные. 2. Увеличить на 4 все элементы в первой половине массива A (считать, что в массиве чётное число элементов).
Ответы (1)
Составьте программу в Паскале для поиска: a) суммы положительных элементов массива от а от 1 до 100, введенных с клавиатуры b) произведения отрицательных элементов массива а от 1 до 100 c) количества нулевых элементов массива с сотней элементов
Ответы (1)
1. Массив и 4 целых чисел вводится с клавиатуры. Найти и вывести произведение элементов массива. 2. Массив из 6 отрицательных и положительных целых чисел вводится в области описания констант. Найти сумму положительных элементов массива. 3.
Ответы (1)
25. Дан одномерный массив. Подсчитать количество положительных и отрицательных элементов. Нулевых элементов в массиве нет.
Ответы (1)