Задать вопрос
30 сентября, 05:38

Помогитe составить программу на Free Pascal.

Дано натуральное число. Верно ли, что произведение его цифр не больше 50

+3
Ответы (1)
  1. 30 сентября, 06:30
    0
    Если число не слишком большое, то:

    var n, p:integer;

    begin

    write ('n = ') ;

    readln (n) ;

    p:=1;

    while n>0 do

    begin

    p:=p * (n mod 10) ;

    n:=n div 10;

    end;

    if p<=50

    then writeln ('Произведение цифр числа = ', p,' (< = 50) ')

    else writeln ('Произведение цифр числа = ', p,' (> 50) ') ;

    end.

    Пример:

    n = 456

    Произведение цифр числа = 120 (> 50)
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Помогитe составить программу на Free Pascal. Дано натуральное число. Верно ли, что произведение его цифр не больше 50 ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Составьте программу в Pascal ABC. Известно, что X кг конфет стоит A рублей. Определить, сколько стоит 1 кг и Y кг этих же конфет. 2. Составьте программу в Pascal ABC. Дано двузначное число. Найти сумму и произведение его цифр. 3.
Ответы (1)
Дано натуральное число: определить а) количество цифр в нем б) сумму его цифр в) произведение его цифр г) среднее арифметическое его цифр д) сумму квадратов его цифр е) сумму кубов его цифр ж) его первую цифру з) сумму его первой и последней цифр
Ответы (1)
1. Дано натуральное число. Верно ли, что сумма его цифр есть четное число, а само число не превышает b? 2. Дано натуральное число. Верно ли, что сумма его цифр больше m а само число делится на n?
Ответы (1)
Помогите решить! 1) Дано натуральное трехзначное число N. Определить сумму и произведение его цифр. 2) Дано натуральное трехзначное число N. Найдите число, образованное перестановкой цифр исходного числа в обратном порядке.
Ответы (1)
6.22) Дано натуральное число. Определить: а) количество цифр 3 в нем; б) сумму его цифр, больших пяти; в) произведение его цифр, больших семи; 6.26) Дано натуральное число. а) определить его максимальную цифру. б) определить его минимальную цифру.
Ответы (1)