Задать вопрос
14 июня, 22:51

Задание 4

Написать программу, создающую одномерный массив из 15 элементов. Значения членов массива вводятся при выполнении программы. Программа должна находить минимальный и максимальный члены массива и их номера.

+3
Ответы (2)
  1. 15 июня, 00:02
    0
    Программа на Паскаль.

    Program Dik;

    Var

    i, min, max, minnum, maxnum: integer;

    a: array[1 ... 15] of integer;

    Begin

    for i: = 1 to 15 do

    readln (a[i]) ;

    max:=a[1]; min:=a[1];

    for i: = 1 to 15 do begin

    if a[i]
    min:=a[i]; minnum:=i;

    end;

    if a[i]>max then begin

    max:=a[i]; maxnum:=i;

    end;

    end;

    writeln ('max=', max) ;

    writeln ('min=', min) ;

    writeln ('maxnum=', maxnum) ;

    writeln ('minnum=', minnum) ;

    end.
  2. 15 июня, 00:14
    0
    Var a: array[1 ... 15] of integer;

    i, imin, imax: integer;

    begin

    imax:=1;

    imin:=1;

    for i:=1 to 15 do

    begin

    readln (a[i]) ;

    if a[i]
    if a[i]>a[imax] then imax:=i;

    end;

    writeln ('Минимальный член массива ', a[imin], ', его номер ', imin) ;

    writeln ('Максимальный член массива ', a[imax], ', его номер ', imax) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Задание 4 Написать программу, создающую одномерный массив из 15 элементов. Значения членов массива вводятся при выполнении программы. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Написать программу, создающую одномерный массив из 10 элементов. Значения членов массива вводятся при выполнении программы. Программа должна определять сумму отрицательных членов массива.
Ответы (1)
Хотя бы 3-4 задачи! 1) Дан одномерный целочисленный массив размерностью N. Найдите количество элементов, которые кратны 3 (5). 2) Дан одномерный целочисленный массив А, состоящий из N элементов. Найти сумму всех четных элементов массива.
Ответы (1)
1. заполните одномерный массив B1 размерностью в N (< 30 задает пользователь при выполнении программы) элементов так, чтобы каждый элемент с четным номером был равен половине своего номера, а каждый элемент с нечетным номером - количеству элементов
Ответы (1)
1) Дан одномерный массив А[N], - целых чисел. Заменить все большие 7 члены массива числом 7. Найти количество таких членов. 2) Задан массив из 10 элементов, найти произведение элементов массива. Задача №3.
Ответы (1)
дан массив из семи элементов написать программу подсчитывающую среднее второго и предпоследнего элементов массива дан целочисленный массив из 10 элементов написать программу находящую сумму элементов массива красных 3 ил 5 дан целочисленный массив
Ответы (1)