Задать вопрос
15 мая, 03:07

Дано натуральное число N и последовательность целых чисел a1 a2 an заданные случайным образом из диапазона [-35; 25]. Удвоить все отрицательные числа нечётные этой последовательности. Решить задачу для n=10

+3
Ответы (1)
  1. 15 мая, 03:16
    0
    Var

    A: array [1 ... 1000] of integer;

    i, n:integer;

    begin

    readln (N) ;

    for i:=1 to N do

    begin

    A[i]:=random (61) - 35;

    write (A[i],' ') ;

    end;

    writeln;

    for i:=1 to N do

    begin

    if (A[i]<0) and (A[i]mod 2=-1) then

    A[i]:=A[i]*2;

    write (A[i],' ') ;

    end;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дано натуральное число N и последовательность целых чисел a1 a2 an заданные случайным образом из диапазона [-35; 25]. Удвоить все ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Дано натуральное число N и последовательность а1, а2, ... аN натуральных чисел, заданных случайным образом из диапазона [3; 100]. Умножить все элементы этой последовательности, кратные 3, на третий элемент.
Ответы (1)
С++ Так что бы программа просила в вести значение на русском 1. Напишите программу, которая вычисляет сумму целых чисел от а до 500 (значение a вводится с клавиатуры). 2. Найти среднее арифметическое всех целых чисел от 1 до 1000. 3.
Ответы (1)
Дан массив натуральных чисел заданных случайным образом из диапазона от 0 до 20 и число х из этого же диапазона. Длина массива равна N. Вставить число х после первого элемента кратного пяти
Ответы (2)
Дано натуральное число N и массив натуральных чисел А, заданных случайным образом из диапазона от 30 до 60. Найти минимальный элемент и его номер. Решить задачу для N=10. на Паскале.
Ответы (2)
1. Напишите программу, которая в последовательности натуральных чисел определяет количество чисел, кратных 4. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, кратное 4.
Ответы (1)