Задать вопрос
19 ноября, 13:19

По данному фрагменту кода выясните, какими числами заполняется целочисленный массив А из десяти элементов:

А[1]:=10;

x:=3;

y:=-1;

for i:=2 to 10 do

begin

x:=x+2;

y:=y * (-1) ;

А[i]:=А[i-1]-x*y;

end;

Найдите сумму элементов массива с чётными индексами. В ответе укажите только число, без каких-либо знаков препинания, например, 100

+1
Ответы (1)
  1. 19 ноября, 15:42
    0
    Код полностью

    var

    a: array[1 ... 10] of integer;

    x, y, i, s: integer;

    begin

    a[1] : = 10;

    x : = 3;

    y : = - 1;

    for i : = 2 to 10 do

    begin

    x : = x + 2;

    y : = y * (-1) ;

    a[i] : = a[i - 1] - x * y;

    write (a[i], ' ') ;

    if i mod 2 = 0 then s : = s + a[i];

    end;

    writeln;

    writeln (s) ;

    end.

    Ответ 5
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «По данному фрагменту кода выясните, какими числами заполняется целочисленный массив А из десяти элементов: А[1]:=10; x:=3; y:=-1; for i:=2 ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Хотя бы 3-4 задачи! 1) Дан одномерный целочисленный массив размерностью N. Найдите количество элементов, которые кратны 3 (5). 2) Дан одномерный целочисленный массив А, состоящий из N элементов. Найти сумму всех четных элементов массива.
Ответы (1)
дан массив из семи элементов написать программу подсчитывающую среднее второго и предпоследнего элементов массива дан целочисленный массив из 10 элементов написать программу находящую сумму элементов массива красных 3 ил 5 дан целочисленный массив
Ответы (1)
Решите задачи: 1) Составьте программу ввода элементов массива [1 ... 8] с клавиатуры и вывода на экран элементов массива с отрицательными значениями. 2) Составьте программу, которая заполняет массив а [1 ...
Ответы (1)
По данному фрагменту кода выясните, какое значение переменной Х было подано на входе, если известно, что в результате выполнения данного кода на выходе значение переменной Y равно 229345007.
Ответы (1)
Массив заполнен случайным образом 20 числами в интервале от 0 до 100. 1) найти максимальный и минимальный элемент массива, а так же их сумму 2) найти среднее арифметическое элементов массива 3) из элементов массива сформировать два массива с четными
Ответы (1)