Задать вопрос
4 марта, 04:24

Написать программу на Pascal, либо C + + и составить блок-схему

Даны натуральные числа A1, A2 ... Признак конца последовательности 99. Найти количество положительных чисел и удвоенное количество отрицательных чисел.

+3
Ответы (1)
  1. 4 марта, 06:53
    0
    Подключи библиотеки iostream и Windows. h

    int main () {

    int nNumsCount = 0,

    pNumsCount;

    int number = 0;

    while (std::cin >> number && number! = 99) {

    if (number < 0)

    ++nNumsCount;

    if (number > 0)

    ++pNumsCount;

    }

    std::cout << pNumsCount << '/n' << 2*nNumsCount << std::endl;

    system ("pause") ;

    return 0;

    }
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Написать программу на Pascal, либо C + + и составить блок-схему Даны натуральные числа A1, A2 ... Признак конца последовательности 99. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1) Вычислить длину окружности и площадь круга одного и того же заданного радиуса R. Pascal (желательно с блок-схемой) 2) Найти сумму членов арифметической прогрессии, если известны её первый член, знаменатель и число членов прогрессии Pascal
Ответы (1)
Составить программу: 1. Дана последовательность чисел. Найти количество отрицательных элементов. Последовательность целых чисел Найти сумму между максимальными и минимальным элементом последовательность 0-признак конца ведения последовательности. 2.
Ответы (1)
1. Напишите программу, которая в последовательности натуральных чисел определяет количество чисел, кратных 4. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, кратное 4.
Ответы (1)
Определить среди 3 введенных чисел (a, b, c) количество отрицательных и положительных. Если больше положительных, то найти минимум из этих 3 чисел, а иначе найти максимум. (нужно нарисовать блок схему и написать программу в паскале)
Ответы (1)
1. Составьте программу в Pascal ABC. Даны три числа. Найти сумму двух наибольших из них. 2. Составьте программу в Pascal ABC.
Ответы (1)