Задать вопрос
1 июля, 18:51

По данному фрагменту кода выясните, какое значение переменной Х было подано на входе, если известно, что в результате выполнения данного кода на выходе значение переменной Y равно 229345007.

var X, Y, i : longint;

begin

readln (X) ;

Y: = 1;

for i: = 1 to 5 do

Y: = Y * X;

writeln (Y) ;

end.

В ответе укажите только число, без каких-либо знаков препинания, например, 100

+5
Ответы (1)
  1. 1 июля, 21:06
    0
    Х = (229,345,007) ^ (1:5) = 47

    проверка

    у=1*47=47

    у=47*47=2209

    у=2209*47=103823

    у=103823*47=4879681

    у=4879681*47=229345007 (верно)

    ответ х=47
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «По данному фрагменту кода выясните, какое значение переменной Х было подано на входе, если известно, что в результате выполнения данного ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
По данному фрагменту кода выясните какое значение переменной X было подано на входе если известно что в результате выполнения данного кода на выходе значение переменной Y равно 229345007.
Ответы (1)
Сделать так чтобы Writeln был заменен другим словом и повторялься не больше двух раз program choise; var N_M:integer; writeln (' введи номер месяца ') ; readln (N_M) ; case N_M of 1:writeln (' январь ') ; 2:writeln (' февраль ') ;
Ответы (1)
Исполнитель "Умник" получает на входе число, обрабатывает его, и на выходе выдает другое число. Например: на входе 100 = на выходе 25; на входе 48 = на выходе 3; на входе 232 = на выходе 29; на входе 448 = на выходе 7.
Ответы (1)
Как сделать теперь без массива (паскале) ? var nm:array of integer; j, l:integer; begin nm: = new integer[3] (random (20), random (20), random (20)) ; writeln ('nm[0] = ', nm[0]) ; writeln ('nm[1] = ', nm[1]) ; writeln ('nm[2] = ', nm[2]) ;
Ответы (1)
Почему выводится ноль в программе? program pr1; var a: real; n: longint; function power (a:real; n:longint) : real; begin var i: integer; var anew: real; anew:=a; for i: = 2 to n do begin a:=a*anew; end; end; begin readln (a, n) ;
Ответы (1)