Задать вопрос
23 декабря, 05:46

Запас рыбы в пруду х тон. Ежегодно прирост рыбы составляет 30%, а вылов рыбы у тон. Через сколько запас рыбы станет z тон или меньше. Решить в паскале.

P. S.: неизвестные данные должны вводиться с клавиатуры.

+2
Ответы (1)
  1. 23 декабря, 07:17
    0
    program p24;

    var x, y, z, k, r:real;

    begin

    write ('колитчество рыбы в пруду ') ; readln (x) ;

    write ('сколько ежегодно вылавлеваеться рыбы ') ; readln (y) ;

    write ('z:=') ; readln (z) ;

    r: = (x*30) / 100;

    if (y<=r) then write ('рыба не закончиться никогда')

    else begin

    while (x>z) do begin

    x:=x-y;

    x:=x + ((x*30) / 100) ;

    k:=k+1;

    end;

    if (x<0) then x:=0;

    writeln ('через ', k,' года в пруду останеться ', x,' тон рыбы') ;

    end;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Запас рыбы в пруду х тон. Ежегодно прирост рыбы составляет 30%, а вылов рыбы у тон. Через сколько запас рыбы станет z тон или меньше. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Запас рыбы в пруду оценен в А тонн. Ежегодный прирост рыбы составляет 15%. Ежегодный план отлова - В тонн. Наименьший запас рыбы составляет С тонн. (Запас ниже С тонн не восстанавливается.
Ответы (1)
Запасы рыбы оценены в А тонн. Ежегодный прирост рыбы в пруду 15%. ежегодный план отлова В тонн, наименьший запас рыбы составляет С тонн (запас ниже С тонн уже не восстанавливается).
Ответы (1)
Ежегодный прирост рыбы в пруду 15%. Запасы рыбы оценены в А тонн, ежегодный план отлова В тонн, наименьший запас, ниже которого запас уже не восстанавливается составляет С тонн. Сколько лет можно выдержать заданный план?
Ответы (1)
Напишите программу на языке j&#1072; vascript, которая будет рассчитывать количество теплоты по формуле: Q=c*m * (t2-t1). Данные должны вводиться заранее с клавиатуры.
Ответы (1)
Составить программу вычисления суммы цифр 5-значного числа вводимого с клавиатуры где N вводиться с клавиатуры
Ответы (1)