Задать вопрос
21 марта, 04:05

Получить квадратную матрицу порядка n:

k 0

n-1 n

n-2 n-1 n

...

1 2 3 ... n

Может кто знает как написать программу в Паскале?

+3
Ответы (1)
  1. 21 марта, 07:53
    0
    Const n=6;

    var a:array[1 ... n, 1 ... n] of integer;

    i, j:integer;

    begin

    for i:=1 to n do

    for j:=1 to i do a[i, j]:=n-i+j;

    for i:=1 to n do

    begin

    for j:=1 to n do write (a[i, j]:3) ;

    writeln;

    end;

    end.

    Пример:

    6 0 0 0 0 0

    5 6 0 0 0 0

    4 5 6 0 0 0

    3 4 5 6 0 0

    2 3 4 5 6 0

    1 2 3 4 5 6
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Получить квадратную матрицу порядка n: k 0 n-1 n n-2 n-1 n ... 1 2 3 ... n Может кто знает как написать программу в Паскале? ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Дана квадратная матрица 9-ого порядка. Получить квадратную матрицу того же порядка, в которой элемент равен единице, если соответствующий ему элемент исходной матрицы меньше элемента, расположенного в его строке на главной диагонали, и равен нулю в
Ответы (1)
Помогите, не могу понять, как повернуть матрицу на 90 градус. Сформировать матрицу 4*4, рандомно заполнить, вывести исходную матрицу, а затем повернуть её на 90 градусов и снова вывести. на языке Pascal
Ответы (1)
написать программу в паскале. даны квадратные матрицы а и в порядка n. получить матрицу ab-ba.
Ответы (1)
Колония клеток представляет собой квадратную матрицу порядка N (N < 500). В колонию проникает M (M < 11) вирусов, которые поражают клетки с координатами (X1, Y1), ... (Xm, Ym).
Ответы (1)
Задана матрица (двумерный массив) A размером N x М, состоящая из действительных элементов. Числа M и N вводятся с клавиатуры. Для задания исходной матрицы предусмотреть ввод с клавиатуры или ввод с помощью датчика случайных чисел.
Ответы (1)