Задать вопрос
29 апреля, 19:01

написать программу в паскале. даны квадратные матрицы а и в порядка n. получить матрицу ab-ba.

+3
Ответы (1)
  1. 29 апреля, 22:58
    0
    Var A, B: array [1 ... 10,1 ... 10] of integer;

    i, j, n: integer;

    begin

    Randomize; writeln ('Введите размерность n') ; readln (n) ; writeln ('Матрица А') ;

    for i:=1 to n do begin

    for j:=1 to n do begin

    A[i, j]: = random (10) + 1; write (A[i, j]:3) ; end; writeln; end;

    writeln ('Матрица B') ;

    for i:=1 to n do begin

    for j:=1 to n do begin

    B[i, j]: = random (10) + 2; write (B[i, j]:3) ; end; writeln; end;

    writeln ('Ответ: матрица AB') ;

    for i:=1 to n do

    for j:=1 to n do begin C[i, j]: = (A[i, j]*B[i, j]) ; end; writeln;

    for i:=1 to n do begin

    for j:=1 to n do begin

    write (C[i, j]:3) ; end; writeln; end;

    writeln ('Ответ: матрица ВА') ;

    for i:=1 to n do

    for j:=1 to n do begin D[i, j]: = (B[i, j]*A[i, j]) ; end;

    for i:=1 to n do begin

    for j:=1 to n do begin

    write (D[i, j]:3) ; end; writeln; end;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «написать программу в паскале. даны квадратные матрицы а и в порядка n. получить матрицу ab-ba. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Ввести матрицу. Найти сумму четных элементов матрицы. Если она отрицательна, то заменить элементы четных столбцов матрицы на 1, в ином случае нечетных столбцов на - 1. Матрицу распечатать
Ответы (1)
Задана матрица (двумерный массив) A размером N x М, состоящая из действительных элементов. Числа M и N вводятся с клавиатуры. Для задания исходной матрицы предусмотреть ввод с клавиатуры или ввод с помощью датчика случайных чисел.
Ответы (1)
Для матрицы размером в n строк и m столбцов составить алгоритм и программу вычисления: 1) Сумм элементов каждой нечетной строки матрицы 2) Суммы произведений тангенсов элементов четных строк матрицы.
Ответы (1)
Дана квадратная матрица 9-ого порядка. Получить квадратную матрицу того же порядка, в которой элемент равен единице, если соответствующий ему элемент исходной матрицы меньше элемента, расположенного в его строке на главной диагонали, и равен нулю в
Ответы (1)
Помогите, не могу понять, как повернуть матрицу на 90 градус. Сформировать матрицу 4*4, рандомно заполнить, вывести исходную матрицу, а затем повернуть её на 90 градусов и снова вывести. на языке Pascal
Ответы (1)