Задать вопрос
18 февраля, 21:36

Колония клеток представляет собой

квадратную матрицу порядка N (N < 500). В колонию

проникает M (M < 11) вирусов, которые

поражают клетки с координатами (X1, Y1),

... (Xm, Ym). За одну единицу времени вирус

проникает в клетки, соседние с зараженными (соседними считаются клетки, имеющие

общую сторону).

Требуется написать программу, которая определит

время заражения всей колонии.

+1
Ответы (1)
  1. 18 февраля, 22:01
    0
    Program Task;

    Const N = 499; M = 1;

    Var A: Array [1 ... N, 1 ... N] of Boolean;

    i, j, x, y, t: Integer;

    b: Boolean;

    Begin

    Randomize;

    While i < M Do

    Begin

    x : = Random (N) + 1;

    y : = Random (N) + 1;

    If A[x, y] = False Then

    Begin

    A[x, y] : = True;

    i : = i + 1;

    End;

    End;

    While b = False Do

    Begin

    b : = True;

    For i : = 1 To N Do

    For j : = 1 To N Do

    Begin

    If A[i, j] = True Then

    Begin

    If (i + 1) < = N Then

    A[i + 1, j] : = True;

    If (i - 1) > 0 Then

    A[i - 1, j] : = True;

    If (j + 1) < = N Then

    A[i, j + 1] : = True;

    If (j - 1) > 0 Then

    A[i, j - 1] : = True;

    End;

    End;

    For i : = 1 To N Do

    For j : = 1 To N Do

    If A[i, j] = False Then

    b : = False;

    t : = t + 1;

    End;

    WriteLn (t) ;

    ReadLn;

    End.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Колония клеток представляет собой квадратную матрицу порядка N (N < 500). В колонию проникает M (M < 11) вирусов, которые поражают клетки с ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Получить квадратную матрицу порядка n: k 0 n-1 n n-2 n-1 n ... 1 2 3 ... n Может кто знает как написать программу в Паскале?
Ответы (1)
Дана квадратная матрица 9-ого порядка. Получить квадратную матрицу того же порядка, в которой элемент равен единице, если соответствующий ему элемент исходной матрицы меньше элемента, расположенного в его строке на главной диагонали, и равен нулю в
Ответы (1)
Помогите, не могу понять, как повернуть матрицу на 90 градус. Сформировать матрицу 4*4, рандомно заполнить, вывести исходную матрицу, а затем повернуть её на 90 градусов и снова вывести. на языке Pascal
Ответы (1)
Напишите программу, которая заполняет квадратную матрицу случайными числами в интервале [10,99], а затем записывает нули во все элементы выше главной диагонали. Алгоритм не должен изменяться при изменении размеров матрицы
Ответы (1)
Паскаль Напишите программу, которая заполняет квадратную матрицу случайными числами в интервале [10,99], и находит максимальный и минимальный элементы в матрице и их индексы
Ответы (1)