Задать вопрос
15 января, 17:53

Даны два натуральных числа - двузначное и трехзначное. Найти разность суммы цифр двузначного и трехзначного чисел.

+1
Ответы (1)
  1. 15 января, 21:40
    0
    Program pr;

    var a, b, s1, s2:integer;

    begin

    writeln ('Введите двузначное число') ;

    readln (a) ;

    writeln ('Введите трехзначное число') ;

    readln (b) ;

    s1:=a div10+a mod 10;

    s2:=b div100+b mod10 + (b div10) mod10;

    writeln ('Разность суммы цифр двузначного и трехзначного чисел равна ', s1-s2) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Даны два натуральных числа - двузначное и трехзначное. Найти разность суммы цифр двузначного и трехзначного чисел. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Дано двузначное число. Определить: a. какая из его цифр больше, первая или вторая; b. одинаковы ли его цифры. 2. Дано двухзначное число. Определить, равен ли квадрат этого числа учетверённой сумме кубов его цифр.
Ответы (1)
Сумма цифр. Даны два числа А и В. Подсчитайте кол-во натуральных чисел на отрезке от А до В, сумма цифр которых четна. Программа получает на вход два натуральных числа А и В, не превосходящих 10^9^ А
Ответы (1)
Составте программу, вычисления суммы цифр трёхзначного числа а. Значение а введите с клавиатуры Пример ввода: 375 Пример вывода: Сумма цифр числа 375 равна 15 2) Составте программу, которая получает 'перевёртыш' трёхзначного числа а.
Ответы (1)
Pascal. Сумма квадратов цифр некоторого двузначного числа на 1 больше утроенного произведения этих цифр. После деления этого двузначного числа на сумму его цифр в частном получается 7 и в остатке 6.
Ответы (1)
Если трёхзначное число равно сумме кубов цифр, образующих это число, то такое число называется "магическим". Найти и вывести все "магические числа". (Написать функцию вычисления суммы кубов цифр трёхзначного числа).
Ответы (1)