Задать вопрос
24 июня, 19:47

Сумма цифр.

Даны два числа А и В. Подсчитайте кол-во натуральных чисел на отрезке от А до В, сумма цифр которых четна.

Программа получает на вход два натуральных числа А и В, не превосходящих 10^9^ А<=В. Программа должна вывести одно число - кол-во натуральных чисел, больше или равных А и меньших или равных В, сумма цифр которых четна.

+1
Ответы (1)
  1. 24 июня, 19:53
    0
    Var n, j, i, a, b, c: integer;

    s: string;

    begin

    readln (a, b) ;

    for i : = a to b do

    begin

    s : = inttostr (i) ;

    for j : = 1 to length (s) do

    n : = n + strtoint (s[j]) ;

    if (n mod 2 = 0) then

    inc (c) ;

    end;

    writeln (c) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Сумма цифр. Даны два числа А и В. Подсчитайте кол-во натуральных чисел на отрезке от А до В, сумма цифр которых четна. Программа получает ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1) Напишите программу которая в последствии натуральных чисел определяет, есть ли в последовательности нечетные числа не оканчивающихся на 1. Вход: программа получает на выход кол-во чисел, а затем сами числа.
Ответы (2)
1) Напишите программу которая в последствии натуральных чисел определяет, находит сумму двузначных чисел не кратных 4. В последовательности обязательно имеется двузначное число не кратное 4.
Ответы (1)
1. Напишите программу, которая в последовательности натуральных чисел определяет количество чисел, кратных 4. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, кратное 4.
Ответы (1)
Pascal ABC Напишите программу, которая определяет количество элементов, сумма цифр которых четна. Формат ввода Программа получает на вход последовательность целых чисел, заканчивающаяся нулем (0 - признак окончания ввода).
Ответы (1)
Даны два числа А и В. Подсчитайте количество натуральных чисел на отрезке от А до В, сумма цифр которых четна. Нужна программа в Паскале
Ответы (1)