Задать вопрос
8 июля, 00:55

Даны два числа А и В. Подсчитайте количество натуральных чисел на отрезке от А до В, сумма цифр которых четна. Нужна программа в Паскале

+4
Ответы (1)
  1. 8 июля, 03:44
    0
    Var b, a, d1, d2, i, j: integer;

    c: string;

    begin

    readln (a, b) ;

    for i : = a to b do

    begin

    d1 : = 0;

    c : = inttostr (i) ;

    for j : = 1 to length (c) do

    d1 : = d1 + strtoint (c[j]) ;

    if (d1 mod 2 = 0) then inc (d2) ;

    end;

    writeln (d2) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Даны два числа А и В. Подсчитайте количество натуральных чисел на отрезке от А до В, сумма цифр которых четна. Нужна программа в Паскале ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Сумма цифр. Даны два числа А и В. Подсчитайте кол-во натуральных чисел на отрезке от А до В, сумма цифр которых четна. Программа получает на вход два натуральных числа А и В, не превосходящих 10^9^ А
Ответы (1)
Pascal ABC Напишите программу, которая определяет количество элементов, сумма цифр которых четна. Формат ввода Программа получает на вход последовательность целых чисел, заканчивающаяся нулем (0 - признак окончания ввода).
Ответы (1)
1. Напишите программу, которая в последовательности натуральных чисел определяет количество чисел, кратных 4. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, кратное 4.
Ответы (1)
1) Напишите программу которая в последствии натуральных чисел определяет, есть ли в последовательности нечетные числа не оканчивающихся на 1. Вход: программа получает на выход кол-во чисел, а затем сами числа.
Ответы (2)
Напишите эффективную программу, которая по двум данным натуральным числам m и n, не превосходящим 30000, подсчитывает количество натуральных чисел с последней цифрой 0 на отрезке [m, n] (включая концы отрезка) Программа получает на вход два
Ответы (1)