Задать вопрос
12 августа, 18:19

Напишите эффективную программу, которая по двум данным натуральным числам m и n, не превосходящим 30000, подсчитывает количество натуральных чисел с последней цифрой 0 на отрезке [m, n] (включая концы отрезка) Программа получает на вход два натуральных числа m и n, при этом гарантируется, что 1≤m≤n≤30000. Программа должна вывести одно число: количество натуральных чисел с последней цифрой 0 на отрезке [m, n].

+1
Ответы (1)
  1. 12 августа, 19:21
    0
    Program Pr1;

    uses crt;

    const t=30000;

    var mas:array[1 ... t] of integer;

    i, n, m, l:integer;

    begin

    clrscr;

    for i:=1 to t do mas[i]:=i;

    writeln ('введите n и m') ;

    readln (n, m) ;

    l:=0;

    for i:=n to m do if mas[i] mod 10=0 then l:=l+1;

    writeln (l) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Напишите эффективную программу, которая по двум данным натуральным числам m и n, не превосходящим 30000, подсчитывает количество ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Решить задачу "напишите эффективную программу, которая по двум данным натуральным числам а и б не превосходящим 30 тысяч подсчитывает количество чётных натуральных чисел на отрезке а и б, включая концы отрезка
Ответы (1)
1. Напишите программу, которая в последовательности натуральных чисел определяет количество чисел, кратных 4. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, кратное 4.
Ответы (1)
1) Напишите программу которая в последствии натуральных чисел определяет, есть ли в последовательности нечетные числа не оканчивающихся на 1. Вход: программа получает на выход кол-во чисел, а затем сами числа.
Ответы (2)
Напишите программу, которая по двум данным числам [ a, b] (включая концы отрезка) Программа получает на вход два натуральных числа a и b.
Ответы (1)
1) Напишите программу которая в последствии натуральных чисел определяет, находит сумму двузначных чисел не кратных 4. В последовательности обязательно имеется двузначное число не кратное 4.
Ответы (1)