Задать вопрос
23 мая, 10:15

Напишите программу, которая по двум данным числам [ a, b] (включая концы отрезка) Программа получает на вход два натуральных числа a и b. Программа должна вывести одно число: количество чётных чисел на отрезке [ a, b ]

Входные данные: 10, 20

Выходные данные: 6

+3
Ответы (1)
  1. 23 мая, 11:10
    0
    Program ryazantsev;

    var a, b, i, count:integer;

    begin

    readln (a, b) ;

    count:=0;

    for i:=a to b do if i mod 2=0 then count:=count+1;

    writeln (count)

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Напишите программу, которая по двум данным числам [ a, b] (включая концы отрезка) Программа получает на вход два натуральных числа a и b. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Уровень B. Задача M. Две одинаковые цифры рядом Напишите программу, которая определяет, верно ли, что введённое число содержит две одинаковых цифры, стоящие рядом (как, например, 221). Входные данные Входная строка содержит одно натуральное число.
Ответы (1)
Напишите эффективную программу, которая по двум данным натуральным числам m и n, не превосходящим 30000, подсчитывает количество натуральных чисел с последней цифрой 0 на отрезке [m, n] (включая концы отрезка) Программа получает на вход два
Ответы (1)
1. Напишите программу, которая в последовательности натуральных чисел определяет количество чисел, кратных 4. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, кратное 4.
Ответы (1)
1) Напишите программу которая в последствии натуральных чисел определяет, есть ли в последовательности нечетные числа не оканчивающихся на 1. Вход: программа получает на выход кол-во чисел, а затем сами числа.
Ответы (2)
Помогите решить! 1))) Вводятся 4 числа: a, b, c и d. Выведите все числа на отрезке от a до b, дающие остаток c при делении на d Входные данные 1 4 1 2 выходные данные 1 3 Входные данный 1 5 0 4 выходные данные 4 2))) Выведите все числа на отрезке от
Ответы (1)