Задать вопрос
17 сентября, 19:08

Составить программу, классифицирующую треугольники по сторонам, если заданы градусные меры трех углов (равносторонний, равнобедренный, разносторонний, прямоугольный).

+3
Ответы (1)
  1. 17 сентября, 19:44
    0
    Var a, b, c: integer;

    begin

    write ('Введите углы a, b, c >> ') ;

    readln (a, b, c) ;

    if a+b+c = 180 then

    if (a>0) and (b>0) and (c>0) then

    begin

    if (a=b) and (b=c) then writeln ('Равносторонний ') ;

    if ((a=b) and (ac)) or ((b=c) and (ba)) or ((a=c) and (cb)) then writeln ('Равнобедренный ') ;

    if (ab) and (bc) and (ac) then writeln ('Разносторонний ') ;

    if (a=90) or (b=90) or (c=90) then writeln ('Прямоугольный ') ;

    if (a>90) or (b>90) or (c>90) then writeln ('Тупоугольный ') ;

    if (a<=89) and (b<=89) and (c<=89) then writeln ('Остроугольный ')

    end

    else

    writeln ('Углы должны быть больше 0')

    else

    writeln ('Сумма углов не равна 180 градусам') ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составить программу, классифицирующую треугольники по сторонам, если заданы градусные меры трех углов (равносторонний, равнобедренный, ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Составить программу на языке кумир по трем введенным сторонам надо сказать возможно ли существование такого треугольника и если да, то какой он: разносторонний, равносторонний или равнобедренный
Ответы (1)
Написать программу, классифицирующую треугольники (равнобедренные, равносторонние, разносторонние), если даны стороны.
Ответы (1)
Написать программу которая классифицирует треугольники равнобедренный, равносторонний, прямоугольный, если даны 3 стороны треугольника.
Ответы (1)
Даны 3 стороны треугольника, составить программу в которой нужно определить равносторонний ли треугольник, если равносторонний, то вывести на экран сообщение треугольник - равносторонний
Ответы (1)
Написать программу в паскале. - Составить программу классификации треугольников по сторонам (равнобедренный, равносторонний, произвольный).
Ответы (1)