Задать вопрос
19 февраля, 12:24

Написать программу которая классифицирует треугольники равнобедренный, равносторонний, прямоугольный, если даны 3 стороны треугольника.

+2
Ответы (1)
  1. 19 февраля, 13:35
    0
    Var a, b, c:real;

    begin

    writeln ('Введите 1 сторону треугольника') ;

    readln (a) ;

    writeln ('Введите 2 сторону треугольника') ;

    readln (b) ;

    writeln ('Введите 3 сторону треугольника') ;

    readln (c) ;

    if (a=b) and (b=c) then writeln ('Равносторонний треугольник')

    else if (a=b) or (b=c) or (a=c) then writeln ('Равнобедренный треугольник')

    else if (sqr (a) = sqr (b) + sqr (c)) or (sqr (b) = sqr (a) + sqr (c)) or (sqr (c) = sqr (b) + sqr (a)) then writeln ('Прямоугольный треугольник')

    else writeln ('Обычный треугольник') ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Написать программу которая классифицирует треугольники равнобедренный, равносторонний, прямоугольный, если даны 3 стороны треугольника. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Даны 3 стороны треугольника, составить программу в которой нужно определить равносторонний ли треугольник, если равносторонний, то вывести на экран сообщение треугольник - равносторонний
Ответы (1)
Составить программу, классифицирующую треугольники по сторонам, если заданы градусные меры трех углов (равносторонний, равнобедренный, разносторонний, прямоугольный).
Ответы (1)
Употребляя слова "все", "некоторый", "каждый", "ни один", установите отношения между понятиями: а) "прямоугольный треугольник" и "равнобедренный треугольник" б) "равносторонний треугольник" и "равнобедренный треугольник" в) "прямоугольник" и "ромб"
Ответы (1)
Вычислить произведение четырех натур. чисел, используя только операцию сложения. (Язык пр:pascal) 1) Написать программу (обычную) 2) Написать программу с использованием процедуры 3) Написать программу с исп. функции 4) Написать программу с исп.
Ответы (1)
Написать программу в паскале. - Составить программу классификации треугольников по сторонам (равнобедренный, равносторонний, произвольный).
Ответы (1)