Задать вопрос
7 сентября, 20:43

Написать программу, классифицирующую треугольники (равнобедренные, равносторонние, разносторонние), если даны стороны.

+4
Ответы (1)
  1. 7 сентября, 23:23
    0
    var a, b, c: real;

    begin

    write ('Введите стороны>> ') ;

    read (a) ;

    read (b) ;

    readln (c) ;

    if (a = b) and (b = c) then

    write ('Треугольник равносторонний')

    else if (a = b) or (b = c) or (a = c) then

    write ('Треугольник равнобедренный')

    else write ('Треугольник разносторонний') ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Написать программу, классифицирующую треугольники (равнобедренные, равносторонние, разносторонние), если даны стороны. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Составить программу, классифицирующую треугольники по сторонам, если заданы градусные меры трех углов (равносторонний, равнобедренный, разносторонний, прямоугольный).
Ответы (1)
Вычислить произведение четырех натур. чисел, используя только операцию сложения. (Язык пр:pascal) 1) Написать программу (обычную) 2) Написать программу с использованием процедуры 3) Написать программу с исп. функции 4) Написать программу с исп.
Ответы (1)
Написать программу на языке Паскаль. 1. Написать программу из 3 введенных значений. Найти максимальное 2. Написать программу запрашивающую номер класса и выводящееся сообщения если 1-4 класса-младшая школа, 5-9-средняя, 10-11-старшая 3.
Ответы (1)
Написать программу которая классифицирует треугольники равнобедренный, равносторонний, прямоугольный, если даны 3 стороны треугольника.
Ответы (1)
1. Даны два ненулевых числа а и b. Напишите программу для нахождения суммы, разности, произведения и частного. 2. Напишите программу для нахождение периметра и площади прямоугольного треугольника, если даны длины его катетов а и b. 3.
Ответы (1)