Задать вопрос
26 ноября, 19:09

Задача контролирующая программа. Предлагаеться 10 задач на сложение двух целых двузначных. Числа задаются случайным образом. Каждый ответ комментируется - правильно или вы ошиблись. после выполнения всех заданий выдаётся количество правильных ответов и выставляются оценки. Язык поскаль, делфи.

+2
Ответы (1)
  1. 26 ноября, 22:27
    0
    Var a, b, c, i, sum, cp:integer;

    begin

    sum:=0;

    cp:=0;

    Randomize;

    writeln ('Посчитайте сложение:') ;

    while i<10 do

    begin

    a:=random (40) + 10;

    b:=random (60) + 10;

    sum:=a+b;

    write ('Сколько будет ', a,'+', b,' = ') ;

    read (c) ;

    if c=sum then begin

    cp:=cp+1;

    writeln ('Молодец!') ;

    end else writeln ('Неправильно') ;

    i:=i+1;

    end;

    writeln ('Всего правильных ответов ', cp) ;

    write ('Оценка:') ;

    if (cp<=4) then write ('Очень плохо (2) ') else

    if (cp>=5) and (cp<=6) then write ('Удовлетворительно (3) ') else

    if (cp>=7) and (cp<=8) then write ('Хорошо (4) ') else

    if (cp>=9) then write ('Отлично! (5) ') ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Задача контролирующая программа. Предлагаеться 10 задач на сложение двух целых двузначных. Числа задаются случайным образом. Каждый ответ ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Составить программу оценки на соревнованиях по фигурному катанию выставляются 9 судьями. потом одна самая высокая и самая низкие оценки отбрасываются и в зачет идет среднее арифметическое оставшихся оценок.
Ответы (1)
Написать программу на Делфи Дан массив целых чисел (n=25), заполненный случайным образом числами из промежутка [-10,50]: 1) заменить максимальный элемент массива на среднее арифметическое значение этого массива;
Ответы (1)
Помогите сделать программу в Паскале В котором 1) Программа выдает сообщение "Вы маль или дево" 2) Пользователь в переменную ST1 задает значение маль или дево 3) Программа выдает сооб "Ты пошла бы играть в куклы" 4) Вводить ответ через переменную
Ответы (1)
1. определить значение переменной А после выполнения оператора X:=5; if X>-3 then A:=X mod 2 else A:=abs (X) ; 2. определить значение переменной А после выполнения оператора X:=-26; Y:=6; if X div Y=4 then A:=X mod Y else A:=X*Y; 3.
Ответы (1)
3. Чему будет равно значение целой переменной a после выполнения этого фрагмента программы? a:=2; for i:=0 to 2 do begin a:=a+i; end; Ответ: введите число 4.
Ответы (2)