Задать вопрос
12 октября, 01:36

Составить программу

оценки на соревнованиях по фигурному катанию выставляются 9 судьями. потом одна самая высокая и самая низкие оценки отбрасываются и в зачет идет среднее арифметическое оставшихся оценок. составьте программу, которая определяет зачетную оценку спортсмена. оценки судей ввести в клавиатуры (целые числа от 1 до 6)

+5
Ответы (1)
  1. 12 октября, 05:14
    0
    Var

    max, min, i:integer;

    b:real;

    a:array[1 ... 9]of integer;

    begin

    for i:=1 to 9 do

    begin

    while (a[i]6) do

    begin

    write (i,' оценка: ') ;

    readln (a[i]) ;

    end;

    if i=1 then

    begin

    max:=a[1];

    min:=a[1];

    end;

    if a[i]>max then max:=a[i];

    if a[i]
    b:=b+a[i];

    end;

    b: = (b-min-max) / 7;

    writeln ('Зачетная оценка: ', b) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составить программу оценки на соревнованиях по фигурному катанию выставляются 9 судьями. потом одна самая высокая и самая низкие оценки ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Вася за 1 четверть получил по информатике 20 оценок. Чтобы вычислить какую оценку он получит необходимо найти среднее арифметическое этих оценок. Напишите программу для нахождения среднего арифметического оценок.
Ответы (1)
Помоги решить. Задача по массивам (паскаль). В спортивных соревнованиях 10 судей выставили свои оценки спортсмену.
Ответы (1)
1. Ввести с клавиатуры длину и ширину прямоугольной двери. Кроме того, ввести длину, ширину и высоту шкафа - прямоугольного параллелепипеда. Выяснить, можно ли пронести шкаф через дверь, не разбирая его. 2. Ввести три вещественных числа с клавиатуры.
Ответы (1)
1. Составьте программу, которая определяет, является ли сумма цифр введенного целого трехзначного числа четным числом. 2. Составьте программу, которая определяет, является ли последняя цифра введенного целого числа нечетным числом. 8 класс.
Ответы (1)
1) напишите программу, которая спрашивает целое число n и считает сумму целых чисел, Муму чётных чисел и сумму нечётных от 1 до n 2) напишите программу, которая спрашивает целые числа а и b и выводит на экран квадраты чисел от а до b 3) напишите
Ответы (1)