Задать вопрос
29 января, 05:44

Написать программу на Делфи

Дан массив целых чисел (n=25), заполненный случайным образом числами из промежутка [-10,50]:

1) заменить максимальный элемент массива на среднее арифметическое значение этого массива;

2) найти сумму положительных элементов, кратных 7.

+4
Ответы (1)
  1. 29 января, 07:33
    0
    Сделано на паскале, тот же делфи, но возможно придется разтосовать кусками, в зависимости от тго что именно надо получить в конце

    const

    n = 25;

    var

    i, imax: integer;

    s, s7: real;

    a, b: array[1 ... n] of real;

    begin

    imax : = 1;

    for i : = 1 to n do

    begin

    a[i] : = random (10 + 50) - 10;

    write (a[i], ' ') ;

    s : = s + a[i];

    if (a[i] > 0) and (round (a[i]) mod 7 = 0) then

    s7 : = s7 + a[i];

    s : = s + a[i];

    if a[imax] < a[i] then imax : = i;

    end;

    writeln () ;

    a[imax] : = s / n;

    for i : = 1 to n do

    write (a[i], ' ') ;

    writeln () ;

    writeln (s7) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Написать программу на Делфи Дан массив целых чисел (n=25), заполненный случайным образом числами из промежутка [-10,50]: 1) заменить ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Дан массив целых чисел (n=25), заполненный случайным образом числами из промежутка [-10,50]: 1) заменить максимальный элемент массива на среднее арифметическое значение этого массива; 2) найти сумму положительных элементов, кратных 7.
Ответы (1)
1. Массив и 4 целых чисел вводится с клавиатуры. Найти и вывести произведение элементов массива. 2. Массив из 6 отрицательных и положительных целых чисел вводится в области описания констант. Найти сумму положительных элементов массива. 3.
Ответы (1)
дан массив из семи элементов написать программу подсчитывающую среднее второго и предпоследнего элементов массива дан целочисленный массив из 10 элементов написать программу находящую сумму элементов массива красных 3 ил 5 дан целочисленный массив
Ответы (1)
Хотя бы 3-4 задачи! 1) Дан одномерный целочисленный массив размерностью N. Найдите количество элементов, которые кратны 3 (5). 2) Дан одномерный целочисленный массив А, состоящий из N элементов. Найти сумму всех четных элементов массива.
Ответы (1)
Помогите решить задачи на паскаль. 1) Дан массив случайных чисел (количество элементов вводите с клавиатуры). Найти произведение всех элементов массива. 2) Дан массив случайных чисел (количество элементов вводите с клавиатуры).
Ответы (1)