Задать вопрос
26 ноября, 16:31

Составить программу, проверяющую является ли число палиндромом

+1
Ответы (1)
  1. 26 ноября, 18:44
    0
    Var S1, S2 : String; N : Byte; Error : Boolean;

    begin

    Write ('Введите натуральное число: ') ; ReadLn (S1) ;

    Error : = False; S2 : = ''; for N : = 1 to Length (S1) do if S1[N] in ['0' ... '9'] then S2 : = S1[N] + S2 else Error : = True;

    if Error then WriteLn ('В числе должны быть только цифры! ')

    else if S1 = S2 then WriteLn ('Введённое число - является полиндромом. ')

    else WriteLn ('Введённое число - не является полиндромом. ')

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составить программу, проверяющую является ли число палиндромом ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Составьте программу, проверяющую, что введенное число является четным или нечетным 2. Составьте программу, проверяющую, что введенное число делится без остатка на 3
Ответы (1)
Составить программу в qbasic проверяющую является ли заданное число палиндромом
Ответы (1)
Строка является палиндромом, если слева направо и справа налево она читается одинаково, например "кабак", "боб", "asdfggf' dsa". Составьте алгоритм и напишите программу, определяющую, является ли строка палиндромом.
Ответы (1)
Слово называется палиндромом, если оно читается одинаково, как слева направо, так и справа налево. Требуется определить, какое минимальное количество букв надо добавить к входному слову справа, чтобы оно стало палиндромом.
Ответы (1)
Написать программу на языке Pascal Палиндромом называется строка, которая одинаково читается как слева направо, так и справа налево.
Ответы (1)