Задать вопрос
25 февраля, 14:55

Слово называется палиндромом, если оно читается одинаково, как слева направо, так и справа налево. Требуется определить, какое минимальное количество букв надо добавить к входному слову справа, чтобы оно стало палиндромом. На вход программе подается строка, состоящая не более чем из 255 символов. Выведите искомое число. паскаль

+1
Ответы (1)
  1. 25 февраля, 18:19
    0
    Var s : String;

    Function isPali (ss : String) : Boolean;

    Begin

    If Length (ss) >0 then isPali: = (ss[1]=ss[Length (ss) ]) and isPali (Copy (ss, 2, Length (ss) - 2))

    else isPali:=True;

    end;

    Function NtoPali (ss : String) : Integer;

    Begin

    If isPali (ss) then NtoPali:=0 else NtoPali:=1+NtoPali (Copy (ss, 2, Length (ss) - 1)) ;

    end;

    Begin

    s:='abcdc'; / / Readln (s) ;

    Writeln (NtoPali (s)) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Слово называется палиндромом, если оно читается одинаково, как слева направо, так и справа налево. Требуется определить, какое минимальное ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Какие из последовательностей могут быть масками? 255.255.255.122 255.255.128.255 255.255.156.0 255.255.255.192 255.255.224.192 255.255.255.128 255.255.128.128 255.255.128.0 255.255.255.102 255.255.248.0
Ответы (1)
Дана матрица размера M х N. Вывести ее элементы в следующем порядке: первая строка слева направо, вторая строка справа налево, третья строка слева направо, четвертая строка справа налево и т. д. в c++, code blocks
Ответы (1)
Строка является палиндромом, если слева направо и справа налево она читается одинаково, например "кабак", "боб", "asdfggf' dsa". Составьте алгоритм и напишите программу, определяющую, является ли строка палиндромом.
Ответы (1)
Написать программу на языке Pascal Палиндромом называется строка, которая одинаково читается как слева направо, так и справа налево.
Ответы (1)
Задача F Четный палиндром Подстрокой строки называется любая непустая последовательность символов в строке. Палиндромом называется строка, которая читается одинаково слева и справа. У Азизхана есть строка S.
Ответы (1)