Задать вопрос
6 июля, 18:27

Написать в программе Паскаль:

Пирожок в столовой стоит а рублей и b копеек. Определите, сколько рублей и копеек нужно заплатить за n пирожков. Программа получает на вход три числа: а, b, n и должна вывести два числа: стоимость покупки в рублях и копейках

+5
Ответы (2)
  1. 6 июля, 19:40
    0
    Program zadanie;

    Var a, b, n:integer;

    Begin

    Writeln ('Введите стоимость пирожка в рублях и копейках') ;

    Readln (a, b) ;

    Writeln ('Сколько нужно купить пирожков') ;

    Readln (n) ;

    Writeln ('Стоимость покупки в рублях=', n*a + ((b*n) div 100)) ;

    Writeln ('Стоимость покупки в копейках=', (n*b) mod 100) ;

    End.
  2. 6 июля, 22:16
    0
    A, b, n, s1, s2 : integer;

    begin

    write ('введите стоимость пирожка в рублях ') ;

    readln (a) ;

    write ('введите стоимость пирожка в копейках ') ;

    readln (b) ;

    write ('введите количество пирожков ') ;

    readln (n) ;

    s1:=a*n;

    s2:=b*n;

    writeln ('стоимость покупки в рублях ', s1) ;

    writeln ('стоимость покупки в копейках ', s2) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Написать в программе Паскаль: Пирожок в столовой стоит а рублей и b копеек. Определите, сколько рублей и копеек нужно заплатить за n ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Помогите решить задачу! Пирожок в столовой стоит a рублей и b копеек. Определите, сколько рублей и копеек нужно заплатить за n пирожков. Программа получает на вход три числа: a, b, n и должна вывести два числа: стоимость покупки в рублях и копейках
Ответы (1)
В Python С клавиатуры вводится натуральное число. Программа должна вывести следующее за ним четное число. Например, если ввести 7, то программа должна вывести 8, а если ввести 8, то программа должна вывести 10.
Ответы (1)
1) Напишите программу которая в последствии натуральных чисел определяет, есть ли в последовательности нечетные числа не оканчивающихся на 1. Вход: программа получает на выход кол-во чисел, а затем сами числа.
Ответы (2)
1. Напишите программу, которая в последовательности натуральных чисел определяет количество чисел, кратных 4. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, кратное 4.
Ответы (1)
Ввести стоимость покупки в магазине, если стоимость меньше тысячи, то вывести "скидки нет", если стоимость от 1000 до 5000, то вывести "скидка 5%", если стоимость свыше 5000, то вывести "скидка 10%". Вывести сумму со скидкой.
Ответы (1)