Задать вопрос
25 декабря, 15:03

Решить задачу в паскале

1. Дано четырехзначное число. Все ли его цифры разные?

+3
Ответы (1)
  1. 25 декабря, 15:18
    0
    Var a, c1, c2 integer; b: bool; begin b:=true; writeln ("Введите четырехзначное число ") ; readln (a) ; c1:=a mod 10; a:=a div 10; while (a>0) do begin c2:=a mod 10; a:=a div 10; if c1 c2 then b: = false; end; if b=true then writeln ("Все цифры данного числа равны") else writeln ("Цифры данного числа различны") ; end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Решить задачу в паскале 1. Дано четырехзначное число. Все ли его цифры разные? ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. дано натурально четырехзначное число. определить цифры этого числа (K, L. M. N) и выяснить можно ли построить ромб со сторонами K, L. M. N. в паскале АВС. 2. дано натурально число N вычислить куб суммы этого числа
Ответы (1)
Дано четырехзначное число n. Выписать число в обратном порядке. n - четырехзначное число (1762) - исходные данные a, b, c, d - цифры этого числа (вспомогательные переменные). m - обратное число (результат) Решить через div и mod
Ответы (1)
Решить в паскале задачу (8-9 класс) : дано четырехзначное число. определить, входят ли в него цифры 2 или 7
Ответы (1)
47. дано целое четырехзначное положительное число n. составьте программу, которая определяет, какая из его цифр больше-вторая или последняя 48 дано целое четырехзначное положительное число n.
Ответы (1)
1) дано четырёхзначное число. вывести максимальную и минимальную цифру. pascal abc 2) дано четырёхзначное число. Что больше: произведение цифр числа или их утроенная сумма. pascal ABC
Ответы (1)